Bug 122228 - [60cat] Remove operation in Design mode doesn't remove the method
[60cat] Remove operation in Design mode doesn't remove the method
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Designer
6.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: bhate
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 14:18 UTC by jlaskowski
Modified: 2007-11-20 13:22 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jlaskowski 2007-11-18 14:18:43 UTC
[ BUILD # : 200711131200 ]
[ JDK VERSION : 1.6.0_02 ]

When in Design mode, executing Remove Operation removes a web method
from the source code, but it is not reflected in Design mode. It
looks like it doesn't remove the method whereas switching to Source
code reveals the truth - it is removed. The tab of the web service
doesn't even show the source code's changed. It's possible to execute
the Remove Operation again, but no changes are done. Very confusing
and visible, hence P1.
Comment 1 Lukas Jungmann 2007-11-18 15:25:46 UTC
Jacek, do you have exact steps for reproducing this? It seems to me like this is valid only for the case there is only
one web method (or one is removing the "last" method). In case the web service have >1 operations then everything works
correctly, right?
Comment 2 jlaskowski 2007-11-18 16:19:28 UTC
Correct. I had only one web method.
Comment 3 Milan Kuchtiak 2007-11-19 11:00:16 UTC
Fixed in trunk:
http://websvc.netbeans.org/source/browse/websvc/design/src/org/netbeans/modules/websvc/design/javamodel/ServiceModel.java?r1=1.14&r2=1.15

Service Model model1 should be merged with ServiceModel model2 even if model2 has no methods
Comment 4 Jaroslav Pospisil 2007-11-19 13:04:29 UTC
Verified in trunk on hudson build 4493.
Comment 5 Roderico Cruz 2007-11-19 17:34:45 UTC
The change looks good. Kindly integrate into the 6.0 branch.
Comment 8 Lukas Jungmann 2007-11-20 13:22:19 UTC
Verified in own 6.0rc2 build from current release60 branch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo