Bug 122200 - JSP scriptlet code completion does not work if freeform project has no src folder
JSP scriptlet code completion does not work if freeform project has no src fo...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@javaee
release601_fixes_candidate1, release6...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 10:25 UTC by marczi
Modified: 2008-02-20 18:18 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Sample freeform project that works in 5.5.1 but not in 6.0 (2.36 KB, application/octet-stream)
2007-11-17 10:26 UTC, marczi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marczi 2007-11-17 10:25:05 UTC
I'm developing a website, where one project contains the Java source, other projects contain the JSP files. The JSP
freeform has no source folders. I set up Tomcat libraries in Web Sources Classpath, however the editor says it can not
find java.lang. It used to be working in 5.5.1.
Comment 1 marczi 2007-11-17 10:26:15 UTC
Created attachment 53155 [details]
Sample freeform project that works in 5.5.1 but not in 6.0
Comment 2 Tomasz Slota 2007-11-19 08:47:44 UTC
Tomasi I think you are more competent to evaluate this issue, it is apparently a classpath problem
Comment 3 Tomas Mysik 2007-11-19 16:09:28 UTC
An easy workaround for this issue is to add some "dummy" folder as your Java Source (just create an empty folder and 
add it to Java Sources using Project Properties). I'll write more information (and file some more issues) tomorrow. 
Thanks for reporting.
Comment 4 Tomas Mysik 2007-11-20 12:11:04 UTC
This issue is fixed, but it's not the most correct fix - if no java source roots are available then the currently 
active platform is returned. Workaround form the previous comment still works of course.

I filed two enhancements, see issue #122368 and issue #122369.

Checking in web/freeform/nbproject/project.xml;
/cvs/web/freeform/nbproject/project.xml,v  <--  project.xml
new revision: 1.24; previous revision: 1.23
done
Checking in web/freeform/src/org/netbeans/modules/web/freeform/WebModules.java;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/WebModules.java,v  <--  WebModules.java
new revision: 1.23; previous revision: 1.22
done
Comment 5 Petr Jiricka 2007-11-29 12:46:57 UTC
Should this issue be fixed in a patch for the update center? It was mentioned in the NB 6.0 NetCat acceptance feedback:
http://qa.netbeans.org/processes/cat/60/results/editor_comments.html
Comment 6 Petr Blaha 2007-11-29 14:34:13 UTC
Reporter, can you please verify the fix in the latest NB build from trunk? The zip is available here
http://deadlock.netbeans.org/hudson/job/trunk/4630/artifact/nbbuild/dist/zip/ thanks for your help
Comment 7 Petr Blaha 2007-12-02 19:43:50 UTC
Since the issue isn't still verified the fix will be in patch2.
Comment 8 Jindrich Sedek 2008-01-31 15:52:51 UTC
classpath seems to be ok - items from libraries are invoked in code completion and no error are highlighted....
verified.
NetBeans IDE Dev (Build 200801310006)

unfortunately jsp editing is influenced by #126401 in actual build - please take a look at this issue while porting fix
into patch
Comment 9 pgebauer 2008-02-07 19:53:13 UTC
The fix has been ported into the release601_fixes branch.

Checking in src/org/netbeans/modules/web/freeform/WebModules.java;
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/Attic/WebModules.java,v  <--  WebModules.java
new revision: 1.21.6.1; previous revision: 1.21
done
Checking in nbproject/project.xml;
/cvs/web/freeform/nbproject/Attic/project.xml,v  <--  project.xml
new revision: 1.23.8.1; previous revision: 1.23
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo