Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 121956 - Can the java formatter be told to leave blank lines as they are
Can the java formatter be told to leave blank lines as they are
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All Windows XP
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 02:29 UTC by gwalbran
Modified: 2008-05-09 04:33 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gwalbran 2007-11-15 02:29:59 UTC
The Options, Java Code, Formatting options allow you to specify how many blank lines should be before and after various
code elements. The problem is I don't always want to do the same thing. For instance if fields are related I don't put
in blank line between them, if they are not related I do put a blank line in.

I would like to tell the formatter to not change blank lines before or after fields. I tried setting the field before
and after options to blank and to -1 but both were treated as if 0 was specified.
Comment 1 gwalbran 2008-05-09 04:33:13 UTC
Netbeans 6.1 java formatter leaves blank lines unchanged


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo