Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 121933 - I18N - Couldn't run EntApp with mbyte in its name
I18N - Couldn't run EntApp with mbyte in its name
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
release601_fixes_candidate1 release60...
: I18N, RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 19:15 UTC by kaa
Modified: 2008-02-20 18:06 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (176.84 KB, image/jpeg)
2007-11-14 19:16 UTC, kaa
Details
mbyte only at the begining (172.37 KB, image/jpeg)
2007-11-14 19:21 UTC, kaa
Details
GF log (45.16 KB, text/plain)
2007-11-14 19:23 UTC, kaa
Details
project (53.58 KB, application/octet-stream)
2007-12-04 14:14 UTC, kaa
Details
ant log (4.58 KB, text/plain)
2007-12-20 16:07 UTC, kaa
Details
gf log (7.74 KB, text/plain)
2007-12-20 16:08 UTC, kaa
Details
ide log (41.31 KB, text/plain)
2007-12-20 16:08 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2007-11-14 19:15:50 UTC
build 1112 RC1, ja_JP

1. Create Enterprise Application using mbyte in its name.
2. Run the app

There is an error while running the app.
Seems r/w problem. See attached image
Comment 1 kaa 2007-11-14 19:16:45 UTC
Created attachment 52996 [details]
image
Comment 2 kaa 2007-11-14 19:19:30 UTC
Evven if the names of the ejb/war/app client do not have mbyte at the end of their names the same problem happens.
Comment 3 kaa 2007-11-14 19:21:19 UTC
Created attachment 52997 [details]
mbyte only at the begining
Comment 4 kaa 2007-11-14 19:23:43 UTC
Created attachment 52998 [details]
GF log
Comment 5 Ken Frank 2007-11-14 19:42:43 UTC
Andrey, if mbyte is in name of ent app, but not in name of the appclient,ejb, webapps projects
as created in the wizard, does the problem still happen ?

To dev,

I don't if this is related at all:
when building it, it mentions the names of the jar and war files with underscore instead
of actual multibyte used ie
Warning: __Jot___Jot_EnterpriseApplication7__-app-client.jar modified in the future.
Warning: __Jot___Jot_EnterpriseApplication7__-ejb.jar modified in the future.
Warning: __Jot___Jot_EnterpriseApplication7__-war.war modified in the future.


also to note, bug filer has installed nb when in that ja locale, which means gf was installed
when also from that locale.

ken.frank@sun.com
Comment 6 kaa 2007-11-14 20:07:37 UTC
the answer is No: if mbyte is in the name of EntApp only, I was able to run it.
Comment 7 Ken Frank 2007-11-15 00:47:26 UTC
adding RELNOTE keyword since if can't be fixed, it will be important
to communicate that non ascii cannot be used in names of ejb, web and appclient
for enterprise app projects.

ken.frank@sun.com
Comment 8 Vince Kraemer 2007-11-15 01:30:03 UTC
work-around: turn off directory deployment

it looks like this is https://glassfish.dev.java.net/issues/show_bug.cgi?id=3456 manifested inside NetBeans.
Comment 9 Ken Frank 2007-11-30 02:24:24 UTC
can team see if it can be fixed for an upcoming patch or 6.0.1 ?

we allow users to use non ascii in names of projects and paths
and fixing this would be consistent with that; I don't know if it
depends on the referred to gf issue though ? that one does not seem
to be i18n related - maybe its really about the underscores vs the mbyte ?
(though we substitute the mbyte with the underscores for the uri)

ken.frank@sun.com
Comment 10 Ken Frank 2007-12-03 16:07:06 UTC
added release60_fixes_candidate2 to status whiteboard
since that is process from sustaining to see if this
can be fixed for patch 2.

Can team see if its a fix that can be done for that patch ?

I can point team to info on the alias and internal sustaining
process about it.

ken.frank@sun.com
Comment 11 Vince Kraemer 2007-12-03 17:11:13 UTC
please attach an ear file that demonstrates this issue.
Comment 12 Vince Kraemer 2007-12-03 19:12:35 UTC
Here is the testing that I have been able to do...

create an ent app that:

has a name that starts with MB chars: dir deploy fails, archive deploy successful
has a name that ends with MB chars  : dir deploy successful, archive deploy successful
has a name with interior MB chars   : dir deploy successful, archive deploy successful
has only MB chars in its name       : dir deploy fails, archive deploy successful

At first glance, it seems like we should disable directory deployment when the ent app has MB characters in its name.

So, how do I tell that a String has MB chars in it?
Comment 13 kaa 2007-12-04 14:14:11 UTC
Created attachment 53838 [details]
project
Comment 14 Ken Frank 2007-12-13 17:55:00 UTC
I found out that for patch2, that fix needs to be in trunk first, then
verified, thus please let us know when fix is there and we'll get it
verified immediately.

ken.frank@sun.com
Comment 16 kaa 2007-12-20 15:35:43 UTC
reproducible:

Product Version: NetBeans IDE 6.0 (Build 200712200000)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
http://smetiste.czech.sun.com/builds/netbeans/6.0.1/daily/latest/
Comment 17 Vince Kraemer 2007-12-20 15:43:02 UTC
Please attach the server log, ide message log and ant output.
Comment 18 kaa 2007-12-20 16:07:55 UTC
Created attachment 54418 [details]
ant log
Comment 19 kaa 2007-12-20 16:08:13 UTC
Created attachment 54419 [details]
gf log
Comment 20 kaa 2007-12-20 16:08:46 UTC
Created attachment 54420 [details]
ide log
Comment 21 Vince Kraemer 2007-12-20 17:19:02 UTC
I think you need to check against a trunk build... not the 6.0.1 build... which is not the trunk...

I think this is the front-door to the bits you need to check... http://bits.netbeans.org/dev/nightly/latest/

Please reopen if this is still an issue in the build from this location.

Comment 22 kaa 2007-12-20 19:27:40 UTC
using 1220 build from http://bits.netbeans.org/dev/nightly/
deployment looks ok.
Comment 23 Karthikeyan Rajeswaran 2008-02-11 03:06:40 UTC
The fix has been ported into the release601_fixes branch.

Checking in DirectoryDeploymentFacade.java;
/cvs/serverplugins/sun/appsrv81/src/org/netbeans/modules/j2ee/sun/ide/j2ee/incrdeploy/Attic/DirectoryDeploymentFacade.java,v
 <--  DirectoryDeploymentFacade.java
new revision: 1.12.10.1; previous revision: 1.12
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo