Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 121477 - JRuby interpreter window
JRuby interpreter window
Status: CLOSED FIXED
Product: ruby
Classification: Unclassified
Component: Code
6.x
All Linux
: P2 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@ruby
release60_fixes_candidate1, release60...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 15:26 UTC by Petr Blaha
Modified: 2007-12-12 16:16 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (178.11 KB, image/png)
2007-11-08 15:27 UTC, Petr Blaha
Details
Stacktrace (2.91 KB, text/plain)
2007-11-21 10:48 UTC, Alexei Mokeev
Details
Patch of fix merged to the release60 branch (3.65 KB, patch)
2007-11-26 23:54 UTC, Torbjorn Norbye
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2007-11-08 15:26:44 UTC
[Build 071108]
Steps:
1) use the fresh NB build full distro
2) install PHP support from UC
3) register local Apache server
4) create new PHp project
ERROR: I was asked for JRuby interpreter, see attachement.
Comment 1 Petr Blaha 2007-11-08 15:27:22 UTC
Created attachment 52725 [details]
screenshot
Comment 2 Alexei Mokeev 2007-11-21 10:48:43 UTC
Created attachment 53286 [details]
Stacktrace
Comment 3 Alexei Mokeev 2007-11-21 10:50:14 UTC
I'm also changing OS to Linux since this issue is not reproducible on Windows. 
Comment 4 Alexei Mokeev 2007-11-23 09:35:39 UTC
Moving the bug to Ruby. After evaluation from Tor the reason is known.
See also: 122616
Comment 5 Andrew Korostelev 2007-11-26 15:08:10 UTC
Was reproduced with SXDE build 78.
Netbeans 6.0 RC1.
Comment 6 Torbjorn Norbye 2007-11-26 23:44:08 UTC
Fixed in trunk.

Do you need this backported to a 6.0/auto update branch?

IDE:-------------------------------------------------
IDE: [11/26/07 3:42 PM] Committing started
Checking in railsprojects/src/org/netbeans/modules/ruby/railsprojects/RailsProject.java;
/cvs/ruby/railsprojects/src/org/netbeans/modules/ruby/railsprojects/RailsProject.java,v  <--  RailsProject.java
new revision: 1.13; previous revision: 1.12
done
Checking in platform/src/org/netbeans/api/ruby/platform/RubyInstallation.java;
/cvs/ruby/platform/src/org/netbeans/api/ruby/platform/RubyInstallation.java,v  <--  RubyInstallation.java
new revision: 1.40; previous revision: 1.39
done
Checking in projects/src/org/netbeans/modules/ruby/rubyproject/RubyProject.java;
/cvs/ruby/projects/src/org/netbeans/modules/ruby/rubyproject/RubyProject.java,v  <--  RubyProject.java
new revision: 1.8; previous revision: 1.7
done
IDE: [11/26/07 3:42 PM] Committing finished
Comment 7 Torbjorn Norbye 2007-11-26 23:54:36 UTC
Created attachment 53519 [details]
Patch of fix merged to the release60 branch
Comment 8 Torbjorn Norbye 2007-11-26 23:55:37 UTC
P.S. Please test this and let me know whether it works as intended - I don't have a JavaFX build etc. myself so I've
only made a theoretical fix of this issue...
Comment 9 Petr Blaha 2007-11-27 10:42:07 UTC
I tested this in the latest trunk build (071127) with PHP project and it works as expected. I suppose that the fix will
work for JavaFX as well.
Comment 10 Alexey Butenko 2007-11-27 16:10:36 UTC
I've verified it in release60 branch (build 071127), but it is not included in RC2 build, because RC2 was created before tor's commit
Comment 11 Torbjorn Norbye 2007-11-27 16:20:53 UTC
Regarding "I've verified it in release60 branch (build 071127), but it is not included in RC2 build, because RC2 was
created before tor's commit":

Note that it won't be in the FCS bits either; I have not integrated the fix, I have only provided a patch for the fix.
We would need to go through the high resistance process if you need this integrated.

So the question is, do you?
Comment 12 Alexei Mokeev 2007-11-27 16:38:01 UTC
No. Let's do not re-spin 6.0 for that.
I had several conversations and it looks very risky at this point.
Probably we will find out a way, how to utilize UC for quiet update.
Comment 13 pgebauer 2007-12-03 19:43:44 UTC
The fix has been ported into the release60_fixes branch.

Checking in railsprojects/src/org/netbeans/modules/ruby/railsprojects/RailsProject.java;
/cvs/ruby/railsprojects/src/org/netbeans/modules/ruby/railsprojects/RailsProject.java,v  <--  RailsProject.java
new revision: 1.12.4.1; previous revision: 1.12
done
Checking in platform/src/org/netbeans/api/ruby/platform/RubyInstallation.java;
/cvs/ruby/platform/src/org/netbeans/api/ruby/platform/RubyInstallation.java,v  <--  RubyInstallation.java
new revision: 1.35.2.1.2.1; previous revision: 1.35.2.1
done
Checking in projects/src/org/netbeans/modules/ruby/rubyproject/RubyProject.java;
/cvs/ruby/projects/src/org/netbeans/modules/ruby/rubyproject/RubyProject.java,v  <--  RubyProject.java
new revision: 1.7.4.1; previous revision: 1.7
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo