Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 120745 - Editor is hanging - no more keyboard input possible
Editor is hanging - no more keyboard input possible
Status: RESOLVED DUPLICATE of bug 119617
Product: ruby
Classification: Unclassified
Component: Editing
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-01 00:33 UTC by graste
Modified: 2007-11-01 09:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump for keyboard input blocking editor window (9.34 KB, text/plain)
2007-11-01 00:35 UTC, graste
Details

Note You need to log in before you can comment on or make changes to this bug.
Description graste 2007-11-01 00:33:48 UTC
When using Netbeans (Beta 2) the editor hangs from time to time. Although I don't know how to reproduce it, it happens 
relatively often on my machine. It happened on Ubuntu Feisty Fawn and several alpha/beta/nightly versions of Netbeans 
and still occurs now that I upgraded to Gutsy Gibbon (Ubuntu 7.10) and Netbeans Beta 2.

I don't know what triggers it, but when it happens, it is not possible to do any keyboard inputs in the editor window. 
Actions like cut/copy/paste triggered by mouse actions (context menu) do work. Files can be saved and reopened without 
problems. Reopening fixes the keyboard behaviour most of the time.

I generated a jstack thread dump for further hints.
Comment 1 graste 2007-11-01 00:35:15 UTC
Created attachment 52201 [details]
Thread dump for keyboard input blocking editor window
Comment 2 graste 2007-11-01 00:38:01 UTC
I just want to point out, that Compiz Fusion was disabled when this issue occured. So it is not related to Compiz 
Fusion or Beryl as I thought earlier.
Comment 3 Jiri Skrivanek 2007-11-01 09:33:37 UTC
It seems to be a duplicate of issue 119617. Please, add additional details requested by vstejskal there.

*** This issue has been marked as a duplicate of 119617 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo