Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 120154 - [60cat] JavaME library project that is requried for my JavaEE project is not build as part of JavaEE project's build
[60cat] JavaME library project that is requried for my JavaEE project is not ...
Status: RESOLVED DUPLICATE of bug 122748
Product: javaee
Classification: Unclassified
Component: EAR
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 11:00 UTC by ieising
Modified: 2007-11-30 17:42 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ieising 2007-10-26 11:00:39 UTC
[ BUILD # : beta2 ]
[ JDK VERSION : 1.6.0_02 ]

Hi,

I have a JavaME library project that is creating a JAR file that is
required for my JavaEE project. So my JavaEE project has a dependency
towards the JavaME project. But when I change something in the JavaME
project's sources, the project is not rebuild as part of a build of
the JavaEE project.

To be thorough, I added the JavaME project as a dependency to the
JavaEE project as well as the EJB project and the WAR project.

Iwan
Comment 1 Milos Kleint 2007-10-26 11:06:59 UTC
not sure if this belongs to mobility or j2ee. please evaluate
Comment 2 Radim Roska 2007-10-26 12:13:48 UTC
i have just tried to reproduce it...like this:

1. create ear project with web project
2. in web project i created servlet 
3. create java application project with Main class, add String variable initialized with some text and create
method(public String getTestString() ) that returns this string..
4. in servlet uncomment commented out.println commands and add there new line out.println(a.getTestString());
5. add javaapplication as library to the web project
6. undeploy and deploy or run works fine...if you open your servlet in browser(e.g.
http://localhost:8080/EnterpriseApplication38-war/NewServlet) the output is ok. Change string in javaapplication,
undeploy and deploy...refresh browser and its ok again.

So please try to reproduce my steps..if it will works the problem has to be elsewhere.

Comment 3 Milos Kleint 2007-10-26 12:19:53 UTC
the report mentions j2ME, not j2SE project.
Comment 4 Radim Roska 2007-10-26 13:48:48 UTC
ok..thats my mistake ;)..sorry for that..

if i create MobileLibrary project with similar steps as i've described lately...its reproducible. 
Comment 5 Radim Roska 2007-10-29 15:52:48 UTC
ok...it looks that problem is really in j2ee..

I've imported mobility library to java application, ejb project and web project.

In java app clean & build builds mobility library too...so its ok.

In ejb and web is this issue valid.

btw other thing is how frequent is this case, who needs to call mobility in j2ee applications??

Workaround is very simple..just build again mobility. So i think we could lower the priority to p4. What do you think? 
Comment 6 ieising 2007-10-29 17:00:51 UTC
We use this a lot, since we use JavaME as a client for the enterprise apps, and to ensure that the data structures used
on the client are the same and compatible with the structures on the server, we define the mobile versions and use them
in the server. Since the mobile is a subset of the enterprise edition, this works very nicely.

I would like to keep this on P3.

Iwan
Comment 7 Tomas Mysik 2007-10-30 11:02:30 UTC
I will look at it.
Comment 8 Tomas Mysik 2007-10-30 17:08:55 UTC
After some investigation I've found out that this applies for Java Library as well, not only for Mobile Library. It's 
not just fault of EAR project but other project types as well. I'll investigate more.
Comment 9 Tomas Mysik 2007-10-31 10:46:38 UTC
The cause of this issue is that there are 2 namespaces for project references - and JavaME library uses the 2nd 
version which is correctly handled only in Java project. Will be fixed soon I hope (there are some complications 
because of EAR project), I'll continue on this issue tomorrow.
Comment 10 Tomas Mysik 2007-11-08 10:19:05 UTC
Reassigning, thanks Davide.
Comment 11 David Konecny 2007-11-29 08:29:46 UTC
*** Issue 122748 has been marked as a duplicate of this issue. ***
Comment 12 David Konecny 2007-11-30 17:42:02 UTC

*** This issue has been marked as a duplicate of 122748 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo