Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 120036 - Reduce memory consumed by CND
Reduce memory consumed by CND
Status: RESOLVED DUPLICATE of bug 123872
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
Sun All
: P2 (vote)
: TBD
Assigned To: Vladimir Kvashin
issues@cnd
other
:
Depends on: 120042 120168 122313
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 14:30 UTC by Vladimir Kvashin
Modified: 2008-07-23 11:16 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2007-10-25 14:30:48 UTC
CND consumes a lot of memory.
Measurements on ~1.2K-files application show that CND consumes about 50Mb.
Firefox project (about 10K source and header files) consumes about 0.5 Gb
The entire Open Solaris sert of projects (about 22K source and header files) can not be open even with 1Gb heap size.
The memory consumption should be reduced.
Comment 1 Vladimir Kvashin 2008-07-23 11:16:27 UTC

*** This issue has been marked as a duplicate of 123872 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo