Bug 120014 - IllegalArgumentException: Already listening to /home/tomas/NetBeansProjects/RailsApplication126/${test/unit}
IllegalArgumentException: Already listening to /home/tomas/NetBeansProjects/R...
Status: RESOLVED FIXED
Product: ruby
Classification: Unclassified
Component: Rails
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Krauskopf
issues@ruby
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: THREAD
: 120992 151911 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 12:25 UTC by Tomas Danek
Modified: 2009-03-15 22:16 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.36 KB, text/plain)
2007-10-25 12:25 UTC, Tomas Danek
Details
messages.log (23.17 KB, text/plain)
2008-07-11 05:05 UTC, tkrd_oiax
Details
stacktrace (5.22 KB, text/plain)
2008-09-05 10:59 UTC, Erno Mononen
Details
stacktrace from c/v test (9.10 KB, text/plain)
2008-10-22 07:33 UTC, Ivan Sidorkin
Details
stacktrace (5.00 KB, text/plain)
2009-02-05 18:15 UTC, tuping
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2007-10-25 12:25:40 UTC
Build: NetBeans IDE Dev (Build 200710241200)
VM: Java HotSpot(TM) Client VM, 1.6.0_01-b06
OS: Linux, 2.6.20-16-generic, i386

User Comments: 
Just created rails project, confirmed wizard defaults. Used Jruby.
Comment 1 Tomas Danek 2007-10-25 12:25:48 UTC
Created attachment 51660 [details]
stacktrace
Comment 2 Martin Krauskopf 2007-10-25 13:13:27 UTC
Race condition. Will synchronize.
Comment 3 Martin Krauskopf 2007-10-25 13:39:33 UTC
rake/src/org/netbeans/modules/ruby/modules/project/rake/FileChangeSupport.java;
new revision: 1.3; previous revision: 1.2
Comment 4 Exceptions Reporter 2008-02-11 17:10:42 UTC
THIS ISSUE HAS ALREADY 10 DUPLICATES
Comment 5 tkrd_oiax 2008-07-11 04:54:05 UTC
I encountered this exception with the trunk 200807101204.
Comment 6 tkrd_oiax 2008-07-11 05:05:36 UTC
Created attachment 64297 [details]
messages.log
Comment 7 tkrd_oiax 2008-07-11 05:16:29 UTC
Unfortunately, I can't reproduce this exception in a regular way.

I will attach the message log enabling detailed logging when available.
Comment 8 Martin Krauskopf 2008-07-11 07:07:06 UTC
*** Issue 120992 has been marked as a duplicate of this issue. ***
Comment 9 Erno Mononen 2008-09-05 10:59:52 UTC
Build: NetBeans IDE Dev (Build 080905)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.5.0_15-b04, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_15-b04
OS: Linux, 2.6.24-19-generic, amd64

User Comments: 
Creating a Rails project.

Stacktrace: 
java.lang.IllegalArgumentException: Already listening to /home/erno/NetBeansProjects/RailsApplication5/app/controllers
        at org.netbeans.modules.ruby.modules.project.rake.FileChangeSupport.addListener(FileChangeSupport.java:92)
        at org.netbeans.modules.ruby.spi.project.support.rake.SourcesHelper$SourcesImpl.listen(SourcesHelper.java:475)
        at org.netbeans.modules.ruby.spi.project.support.rake.SourcesHelper$SourcesImpl.getSourceGroups(SourcesHelper.java:409)
        at org.netbeans.modules.ruby.railsprojects.RailsSources$2.run(RailsSources.java:114)
        at org.netbeans.modules.ruby.railsprojects.RailsSources$2.run(RailsSources.java:105)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
Comment 10 Erno Mononen 2008-09-05 10:59:57 UTC
Created attachment 69133 [details]
stacktrace
Comment 11 Exceptions Reporter 2008-09-18 17:20:22 UTC
This issue has already 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=9242
Comment 12 Martin Krauskopf 2008-09-19 18:17:45 UTC
Very likely related to issue 119244. Bug in Rails project. I'll try to come with fix.
Comment 13 Martin Krauskopf 2008-09-20 08:51:40 UTC
Tried to fix, please reopen whether you can still reproduce.

Fixed: #e2d38a5c0059
Comment 14 Quality Engineering 2008-09-20 17:17:19 UTC
Integrated into 'main-golden', will be available in build *200809201401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e2d38a5c0059
User: Martin Krauskopf <mkrauskopf@netbeans.org>
Log: Fixing #120014 by taking back fix for #119244 and workarounding it in the safe way.

#119244: log error: SEVERE: Attempt to call ProjectManager.findProject within the body of ProjectFactory.loadProject
#120014: IllegalArgumentException: Already listening to /RailsApplication/something
Comment 16 Erno Mononen 2008-10-01 16:03:15 UTC
P1 doesn't seem justified, so I'm downgrading this. Happens rarely and the workaround is simple.
Comment 17 Martin Krauskopf 2008-10-09 12:32:33 UTC
New stacktrace is needed. The one from the commit-validation has died, during my vacation. Next time let's put it as
attachment here.
Comment 18 Ivan Sidorkin 2008-10-22 07:33:54 UTC
Created attachment 72444 [details]
stacktrace from c/v test
Comment 19 Martin Krauskopf 2008-10-23 07:21:28 UTC
Fixed: #cdefc815695e

Commit log:
Preventing apparent race condition (similarly to #121059). Utilizing o.o.u.ChangeSupport. 
Comment 20 Quality Engineering 2008-10-24 04:19:39 UTC
Integrated into 'main-golden', will be available in build *200810240201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/cdefc815695e
User: Martin Krauskopf <mkrauskopf@netbeans.org>
Log: #120014: Preventing apparent race condition (similarly to #121059). Utilizing o.o.u.ChangeSupport.
Comment 21 Martin Krauskopf 2008-10-30 22:14:53 UTC
*** Issue 151911 has been marked as a duplicate of this issue. ***
Comment 22 tuping 2009-02-05 18:15:00 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.IllegalArgumentException: Already listening to D:\Projetos\Depot\app\controllers
        at org.netbeans.modules.ruby.modules.project.rake.FileChangeSupport.addListener(FileChangeSupport.java:92)
        at org.netbeans.modules.ruby.spi.project.support.rake.SourcesHelper$SourcesImpl.listen(SourcesHelper.java:475)
        at org.netbeans.modules.ruby.spi.project.support.rake.SourcesHelper$SourcesImpl.getSourceGroups(SourcesHelper.java:409)
        at org.netbeans.modules.ruby.railsprojects.RailsSources$1.run(RailsSources.java:110)
        at org.netbeans.modules.ruby.railsprojects.RailsSources$1.run(RailsSources.java:101)
        at org.openide.util.Mutex.readAccess(Mutex.java:285)
Comment 23 tuping 2009-02-05 18:15:04 UTC
Created attachment 76627 [details]
stacktrace


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo