Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 119879 - Breakpoints are not always shown at the left side-bar while are set
Breakpoints are not always shown at the left side-bar while are set
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
PC All
: P1 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 10:42 UTC by kelahcim
Modified: 2008-07-10 15:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image showing that breakpoint are not properly shown within editor (87.82 KB, application/octet-stream)
2007-10-24 10:43 UTC, kelahcim
Details
Messages log (52.59 KB, text/plain)
2008-04-25 16:08 UTC, pribyl
Details
messages.log (49.14 KB, text/plain)
2008-04-28 14:09 UTC, aldobrucale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kelahcim 2007-10-24 10:42:46 UTC
Hard to reproduce.

1. Create new Web Application project
2. Add new servlet
3. Deploy application to glassfish server
4. enter into debug mode
5. execute application in debug mode
6. set breakpoint within servlet
7. sometimes breakpoints are not shown at the left side-bar
Comment 1 kelahcim 2007-10-24 10:43:23 UTC
Created attachment 51557 [details]
image showing that breakpoint are not properly shown within editor
Comment 2 Vitezslav Stejskal 2007-10-24 13:13:30 UTC
Any idea when? Does closing and reopening the file help? Scrolling outside of the visible area and back? Resetting the
breakpoint? Did you see any exceptions? Could you please attach <userdir>/var/log/messages.log file? Thanks a lot
Comment 3 aldobrucale 2007-11-16 18:16:33 UTC
I've had the same problem in a non-web Java application running Netbeans 6.0-RC1. The line was not highlighted in the
editor. Restarting the IDE everything was alright.
Comment 4 aldobrucale 2007-11-20 14:21:14 UTC
It happened again after working for a while. Closing and reopening the file was not enough to restore the breakoints in
the editor.
Comment 5 Jiri Prox 2008-04-11 00:44:56 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 6 pribyl 2008-04-25 12:00:37 UTC
Kelahcim, Aldobrucale are you still experiencing this problem? Please could you attach the messages.log?
And Aldobrucale, in your case - have you observed this on Linux as well?

Thanks
Comment 7 pribyl 2008-04-25 16:05:54 UTC
Product Version: NetBeans IDE 6.1 RC2 (Build 200804170002)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Well, it just happened to me as well. Although I created several breakpoints, they were not visible in the editor.

And the steps to reproduce are incredibly simple!

1, Create new java project (e.g. javaaplication1)
2, Create a new package (e.g. javaaplication1.logic)
3, drag&drop Main.java into this package (refactoring should run)

and thats it. Try to create a breakpoint now.

I was able to reproduce this couple of times, always with a new usedir. Jirka V. tested this right now with the same result.

I am affraid this is P1
Comment 8 pribyl 2008-04-25 16:08:28 UTC
Created attachment 60698 [details]
Messages log
Comment 9 Jiri Prox 2008-04-25 16:30:07 UTC
The debugging works correctly, only the breakpoints are only not visible in the gutter. They are added to breakpoint
list and debugger stops on them normally. 

This affect only breakpoints, other annotations are ok. 
Comment 10 Martin Entlicher 2008-04-26 10:22:15 UTC
AnnotationProvider.annotate() is not called for renamed file. Since the lookup contains not only FileObject, but also
DataObject, I guess that the client is responsible for listening on DataObject.PROP_PRIMARY_FILE to get the new FileObject.

Moving to debuggerjpda where we implement AnnotationProvider.
Comment 11 Martin Entlicher 2008-04-26 11:04:42 UTC
Fixed in trunk:
changeset:   79256:15fab9719250
http://hg.netbeans.org/main/rev/15fab9719250
Comment 12 Quality Engineering 2008-04-26 15:54:04 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #159 build
Changeset: http://hg.netbeans.org/main/rev/15fab9719250
User: mentlicher@netbeans.org
Log: #119879 - When annotating, listen on the changes of DataObject's primary file.
This is necessary to annotate renamed files.
Comment 13 aldobrucale 2008-04-28 14:06:12 UTC
Yes, I can reproduce it with nb 6.1 RC2 under ubuntu. I'm attaching the message log, in case you still need it.
Comment 14 aldobrucale 2008-04-28 14:09:20 UTC
Created attachment 60748 [details]
messages.log
Comment 15 Martin Entlicher 2008-04-28 16:34:30 UTC
I did not find anything unusual in your message.log file, but thanks anyway. The problem is fixed in trunk (post-6.1
development builds).
Comment 16 rbalada 2008-05-29 12:10:05 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/15fab9719250 from main repository into release61_fixes
repository as http://hg.netbeans.org/release61_fixes/rev/bde0c7a68536

changeset:   77600:bde0c7a68536
tag:         tip
user:        mentlicher@netbeans.org
date:        Sat Apr 26 11:26:43 2008 +0200
summary:     #119879 - When annotating, listen on the changes of DataObject's primary file.
Comment 17 Peter Pis 2008-06-04 20:26:34 UTC
Verified.
Comment 18 Peter Pis 2008-06-19 09:50:51 UTC
Verified with patch2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo