Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 118947 - NbInstaller blocks access to some classes platform apps need
NbInstaller blocks access to some classes platform apps need
Status: RESOLVED DUPLICATE of bug 125655
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@platform
issues@platform
tb20071015
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 22:20 UTC by _ tboudreau
Modified: 2008-12-22 11:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2007-10-15 22:20:52 UTC
I'm at a customer site where they are building on the platform, and they need access to the jax-ws, annotations and jaxb classes.  NbInstaller blocks access to 
them so that modules can load their own versions of these - but they are completely unavailable if there is no module providing them.

Ideal would be to simply load the classes from the module if present, from the boot classpath if not.  Acceptable would be to simply provide a command-line 
switch to turn off loading some of these packages, or to subtract some packages from the full list via a command-line arg or system property.
Comment 1 Jesse Glick 2007-10-15 22:44:54 UTC

*** This issue has been marked as a duplicate of 96711 ***
Comment 2 Jesse Glick 2008-02-16 00:49:31 UTC
x
Comment 3 Jesse Glick 2008-02-16 00:49:46 UTC

*** This issue has been marked as a duplicate of 125655 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo