Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 118849 - Add Select/Unselect All functionality to Encapsulate Fields dialog
Add Select/Unselect All functionality to Encapsulate Fields dialog
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
:
: 116664 127741 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 02:58 UTC by jfosterjr
Modified: 2008-04-29 04:18 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screen capture of Encapsulate Fields dialog (16.56 KB, image/png)
2007-10-15 02:59 UTC, jfosterjr
Details
Encapsulate field dialog box having to select checkbox one by one (36.50 KB, text/plain)
2008-01-22 19:48 UTC, ejvyas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jfosterjr 2007-10-15 02:58:54 UTC
[ BUILD # : 200710140000 ]
[ JDK VERSION : 1.6.0_03 ]

Add Select/Unselect All functionality to Encapsulate Fields dialog. 
This could be column specific such that it would affect only the
getters and/or setters .
Comment 1 jfosterjr 2007-10-15 02:59:56 UTC
Created attachment 50928 [details]
Screen capture of Encapsulate Fields dialog
Comment 2 ejvyas 2008-01-22 19:46:39 UTC
I also experienced the same
Comment 3 ejvyas 2008-01-22 19:48:36 UTC
Created attachment 55396 [details]
Encapsulate field dialog box having to select checkbox one by one
Comment 4 Jan Pokorsky 2008-04-28 17:22:43 UTC
*** Issue 127741 has been marked as a duplicate of this issue. ***
Comment 5 Jan Pokorsky 2008-04-28 17:36:59 UTC
Yes, it would be useful.
Comment 6 Jan Pokorsky 2008-04-28 17:42:44 UTC
*** Issue 116664 has been marked as a duplicate of this issue. ***
Comment 7 Jan Pokorsky 2008-04-28 18:21:52 UTC
implemented as http://hg.netbeans.org/main/rev/ab2b7b02a475
Comment 8 Quality Engineering 2008-04-29 04:18:36 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #164 build
Changeset: http://hg.netbeans.org/main/rev/ab2b7b02a475
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #79042: Encapsulate Fields enhancements
  * select buttons #118849
  * insert point
  * sort by
  * comments #48296, #73477
  * setters for final fields
  * new layout


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo