Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 117743 - I18N should not try to load texts in annotataion from the bundle
I18N should not try to load texts in annotataion from the bundle
Status: RESOLVED DUPLICATE of bug 130797
Product: java
Classification: Unclassified
Component: I18N
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@java
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 10:37 UTC by Jiri Prox
Modified: 2009-01-19 13:57 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2007-10-04 10:37:59 UTC
Product Version: NetBeans IDE Dev (Build 20071004052249) Java: 1.6.0_05-ea; Java HotSpot(TM) Client VM 1.6.0_05-ea-b04
System: Linux version 2.6.5-1.358 running on i386; UTF-8; en_US (nb) Userdir: /home/jp159440/.netbeans/dev

I18N by default should not try to modify hardcoded text in annotations. 
Of course this can be prevented by NOI18N comment

Example:
Calling I18N on following code will produce not compilable code.

public class NewMain {
	
	@SuppressWarnings("deprecation")
	public void method() {
		Thread.currentThread().destroy();
	}
}
Comment 1 Alexey Butenko 2009-01-19 13:18:56 UTC
There is an AnnotationDetector exist in JavaI18NFinder class.
So all annotations will be skipped during Internationalization.
Comment 2 Marian Petras 2009-01-19 13:57:08 UTC
Reopened such that it can be closed as a duplicate.
Comment 3 Marian Petras 2009-01-19 13:57:43 UTC

*** This issue has been marked as a duplicate of 130797 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo