Bug 116926 - Add view whitespace and view end of line to the editor
Add view whitespace and view end of line to the editor
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 with 2 votes (vote)
: 7.1
Assigned To: Milutin Kristofic
issues@editor
: PLAN
: 153012 196305 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 11:11 UTC by xeal
Modified: 2011-09-17 14:16 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (6.02 KB, image/png)
2011-07-16 18:42 UTC, yuriy_lalym
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xeal 2007-09-27 11:11:56 UTC
Every programmer's editor has these two features and it's really disappointing to not find them in NetBeans.

There are some (more or less working) plugins that offer these features, but they should really be part of the core
editor, not some third-party plugin.
Comment 1 Vitezslav Stejskal 2007-09-27 13:45:38 UTC
Could you add links where to find those plugins? Thanks
Comment 2 xeal 2007-09-28 04:22:32 UTC
"Tab Highlighter/Fixer Module and Update of stripwhitespace Module":
http://www.nbextras.org/2006/04/29/1146344949612.html
Comment 3 Jiri Prox 2008-04-11 00:43:25 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 4 Jiri Prox 2008-11-12 10:16:11 UTC
*** Issue 153012 has been marked as a duplicate of this issue. ***
Comment 5 David Strupl 2011-04-21 13:46:29 UTC
View and of line is already implemented by Mila. It is accessible via View --> Show Non-printable Characters. It does not visually mark the space character. Putting this into the plan for 7.1.
Comment 6 Miloslav Metelka 2011-05-19 13:48:53 UTC
View space character implemented:
http://hg.netbeans.org/jet-main/rev/1c1a4b832185
Comment 7 Miloslav Metelka 2011-05-19 13:49:12 UTC
*** Bug 196305 has been marked as a duplicate of this bug. ***
Comment 8 Quality Engineering 2011-05-20 08:56:46 UTC
Integrated into 'main-golden', will be available in build *201105200400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1c1a4b832185
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #116926 - View space as a centered dot '.' character when show non-printing characters.
Comment 9 yuriy_lalym 2011-07-16 18:42:51 UTC
Created attachment 109474 [details]
screenshot

NetBeans IDE Dev (Build 201107160600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
Linux

I do not know that means DocumentView.PRINTING_SPACE (http://hg.netbeans.org/main/rev/1c1a4b832185), but I see no points. 
In a 30 line. From the beginning of line to the word obviously more than one tabulation.
Comment 10 yuriy_lalym 2011-07-16 18:55:49 UTC
And if I get it right, there was integration into 'main - golden' accordingly it becomes DEFECT instead of ENHANCEMENT
Comment 11 Miloslav Metelka 2011-09-16 15:10:56 UTC
Apologies, the commit got lost by a large code rewrite.
http://hg.netbeans.org/jet-main/rev/07bb6e183318
Comment 12 Quality Engineering 2011-09-17 14:16:27 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/07bb6e183318
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #116926 - Add view whitespace and view end of line to the editor - restored fix that got lost by larger code rewrite.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo