Bug 116817 - NPE in o.n.m.s.ui.relocate.RelocateAction.getCurrentURL
NPE in o.n.m.s.ui.relocate.RelocateAction.getCurrentURL
Status: RESOLVED DUPLICATE of bug 122411
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 13:36 UTC by tomzi
Modified: 2008-11-27 05:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.08 KB, text/plain)
2007-09-26 13:36 UTC, tomzi
Details
stacktrace (3.08 KB, text/plain)
2007-09-26 13:37 UTC, tomzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2007-09-26 13:36:13 UTC
Build: NetBeans IDE 6.0 Beta 1 (Build 200709141330)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105
OS: Windows XP, 5.1, x86

User Comments:
Comment 1 tomzi 2007-09-26 13:36:21 UTC
Created attachment 49560 [details]
stacktrace
Comment 2 tomzi 2007-09-26 13:37:11 UTC
Build: NetBeans IDE 6.0 Beta 1 (Build 200709141330)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105
OS: Windows XP, 5.1, x86

User Comments: 
Comment 3 tomzi 2007-09-26 13:37:21 UTC
Created attachment 49561 [details]
stacktrace
Comment 4 Tomas Stupka 2007-10-01 18:25:47 UTC
sorry, but i wasn't able to reproduce.

- what exactly have you done in the ide?
- where does your working copy come from - was it created with the NB client or with some other tool? Could it be that
it was created with a svn client < 1.3?

- could you, please: 
   - try reproduce the error and attach the whole messages.log file?
   - attach a part from your local WC? (e.g. the project root folder with its svn metadata)

thanks


Comment 5 Tomas Stupka 2007-10-30 10:13:07 UTC
no user response for a long time - closing as worksforme
Comment 6 Exceptions Reporter 2008-10-09 08:23:47 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200809170201)
http://statistics.netbeans.org/exceptions/detail.do?id=125353
Comment 7 Tomas Stupka 2008-11-21 14:42:32 UTC
could be caused by the fact that the project root node returns also a shared lib folder which might not be versioned.
see also - issue #151220

fixing in 
changeset:   108560:e284f2e45b12
tag:         tip
user:        Tomas Stupka <tstupka@netbeans.org>
date:        Fri Nov 21 15:12:06 2008 +0100
summary:     #116817  - NPE in o.n.m.s.ui.relocate.RelocateAction.getCurrentURL

however, this also could be caused by the same reason as issue #122411 so setting this also as a duplicate

*** This issue has been marked as a duplicate of 122411 ***
Comment 8 Quality Engineering 2008-11-27 05:33:24 UTC
Integrated into 'main-golden', will be available in build *200811270201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e284f2e45b12
User: Tomas Stupka <tstupka@netbeans.org>
Log: #116817  - NPE in o.n.m.s.ui.relocate.RelocateAction.getCurrentURL


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo