Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 116527 - Update of "Visual Mobily designer" modules on 6.0 Beta1 AUC
Update of "Visual Mobily designer" modules on 6.0 Beta1 AUC
Status: VERIFIED FIXED
Product: updatecenters
Classification: Unclassified
Component: Stable
6.x
All All
: P2 (vote)
: 6.x
Assigned To: rnovak
Autoupdate Masters
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 14:22 UTC by Lukas Hasik
Modified: 2007-10-02 12:42 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments
1. NBM for AUC 6.0beta1 (50.85 KB, application/octet-stream)
2007-09-25 13:07 UTC, David Kaspar
Details
2. NBM for AUC 6.0beta1 (8.92 KB, application/octet-stream)
2007-09-25 13:08 UTC, David Kaspar
Details
3. NBM for AUC 6.0beta1 (27.79 KB, application/octet-stream)
2007-09-25 13:08 UTC, David Kaspar
Details
Replacement of 2. NBM for AUC 6.0beta1 (8.92 KB, application/octet-stream)
2007-09-25 13:21 UTC, David Kaspar
Details
another Replacement of 2. NBM for AUC 6.0beta1 (8.93 KB, application/octet-stream)
2007-09-26 14:52 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2007-09-24 14:22:51 UTC
AUC request:
============
Module: Visual Mobile Designer
AUC Type: Stable (or Beta?)
AUC Version: 6.0 Beta1
Contact: David Kaspar
Reason: Fix of issue 115481
NB signature required: Yes
URLs: TBD
Comment 1 Lukas Hasik 2007-09-24 14:32:02 UTC
David, please reassign to rnovak when you provide the NBMs.

Only Beta1 AUC should be affected!
Comment 2 David Kaspar 2007-09-25 04:49:12 UTC
Issue #115338 has been also backported to the release60_beta1 branch. Therefore there is additional AUC request with
similar description.
Finally there is going to be following modules on AUC:
mobility/designer2/kit
mobility/designer2/io
mobility/designer2/palette

All changes has been committed to the release60_beta1 branch as well as to main trunk. Spec. version has been updated
for "mobility/designer2/io" and "mobility/designer2/palette".
I am not sure whether the "kit" module spec. number should be increased too (I have not done it).

Karol, could you, please, check out release60_beta1 branch and provide NBMs to QA to test it? You would need a valid
keystore (ask Robert Novak for signing details). Also if "kit" module spec. number should be updated as well, then
update it (ask Lukas Hasik about details of spec. number increasing).

Thanks.
Comment 3 rnovak 2007-09-25 12:38:55 UTC
Karol, build just non-signed NBM. I will sign it during upload to UC.
Comment 4 David Kaspar 2007-09-25 13:06:51 UTC
Sorry, my fault. I thought that the nbm is not created without signing. Attaching 3 NBMs for auto-update.
Lukasi, please, try to test it again. with NBMs. Thanks.
Comment 5 David Kaspar 2007-09-25 13:07:38 UTC
Created attachment 49446 [details]
1. NBM for AUC 6.0beta1
Comment 6 David Kaspar 2007-09-25 13:08:04 UTC
Created attachment 49447 [details]
2. NBM for AUC 6.0beta1
Comment 7 David Kaspar 2007-09-25 13:08:37 UTC
Created attachment 49448 [details]
3. NBM for AUC 6.0beta1
Comment 8 David Kaspar 2007-09-25 13:20:18 UTC
Upgrading version of mobility/designer2/kit module:

Checking in manifest.mf;
/cvs/mobility/designer2/kit/manifest.mf,v  <--  manifest.mf
new revision: 1.2.2.1; previous revision: 1.2
done

Is there any other place where the spec. number of mobility/designer2/kit has to be changed too?
Comment 9 David Kaspar 2007-09-25 13:21:16 UTC
Created attachment 49450 [details]
Replacement of 2. NBM for AUC 6.0beta1
Comment 10 David Kaspar 2007-09-25 13:23:52 UTC
Increasing mobility/designer2/kit module spec. number in main trunk to 1.1:

Checking in manifest.mf;
/cvs/mobility/designer2/kit/manifest.mf,v  <--  manifest.mf
new revision: 1.3; previous revision: 1.2
done
Comment 11 rnovak 2007-09-25 13:49:16 UTC
I signed provided NBMs and staged the on Beta UC for NB 6.0 Beta1
Please, proceed with the download test and I'll push them live.
Comment 12 Lukas Hasik 2007-09-26 10:16:45 UTC
the update from staging AUC  doesn't work. I can see the update there but Plugin manager yields to me "Plugin Visual
Mobility designer cannot match its dependencies: module org.netbeans.modules.vmd.io.javame > 1.0.1" 

David, are there correct dependencies?
Comment 13 Lukas Hasik 2007-09-26 12:38:15 UTC
the same happens when I try to install the attached NBMs
Comment 14 Lukas Hasik 2007-09-26 14:52:14 UTC
Created attachment 49569 [details]
another Replacement of 2. NBM for AUC 6.0beta1
Comment 15 Lukas Hasik 2007-09-26 14:53:59 UTC
there was typo in the kit. We fixed. The latest kit works with the palette and io finally. 

Robo, could you upload once more? Thank you.
Comment 16 Karol Harezlak 2007-09-26 15:11:55 UTC
I've updated beta1 branch, There was a problem with dependencies VMD Kit module (wrong dependencies for VMD Java ME IO
instead of VMD IO). It's fixed now. New NBM for update center has been sent to Lukas for testing.  

Checking in project.xml;
/cvs/mobility/designer2/kit/nbproject/project.xml,v  <--  project.xml
new revision: 1.3.2.3; previous revision: 1.3.2.2
Comment 17 rnovak 2007-09-26 16:16:49 UTC
I staged new version od=f org-netbeans-modules-vmd-kit.nbm.
Comment 18 Lukas Hasik 2007-09-27 20:34:59 UTC
thanks, it works now. Push it live, please.
verified by me and Fabi with Beta1 build
Comment 19 rnovak 2007-10-01 13:52:29 UTC
I pushed the VDM modules live.
Comment 20 Lukas Hasik 2007-10-02 12:42:11 UTC
verified in fresh Beta1 build. Update is available at the NetBeans Beta center. When it is installed into Beta1 then it
fixes the broken functionality.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo