Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 115790 - [60cat] NPE upon finishing New > Web Service in EJB project
[60cat] NPE upon finishing New > Web Service in EJB project
Status: RESOLVED DUPLICATE of bug 114391
Product: webservices
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 07:45 UTC by jlaskowski
Modified: 2007-09-18 11:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
NPE stack trace (69.73 KB, text/plain)
2007-09-18 07:46 UTC, jlaskowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jlaskowski 2007-09-18 07:45:34 UTC
[ BUILD # : 200709141330 ]
[ JDK VERSION : 1.6.2 ]

Take a look at the attached messages.log where the stack trace is.
Comment 1 jlaskowski 2007-09-18 07:46:15 UTC
Created attachment 48957 [details]
NPE stack trace
Comment 2 jlaskowski 2007-09-18 08:59:05 UTC
Ok, found out what might be a culprit. Open up the NewWebService.java that represents the SEI from the Files tab. Left
mouse button clicking causes NPE.

java.lang.NullPointerException
	at org.netbeans.modules.j2ee.dd.impl.ejb.annotation.SessionImpl.getLocal(SessionImpl.java:410)
	at org.netbeans.modules.j2ee.ejbcore.api.methodcontroller.AbstractMethodController$1.run(AbstractMethodController.java:85)
	at org.netbeans.modules.j2ee.ejbcore.api.methodcontroller.AbstractMethodController$1.run(AbstractMethodController.java:83)
	at org.netbeans.modules.j2ee.dd.impl.ejb.annotation.EjbJarMetadataModelImpl$1.call(EjbJarMetadataModelImpl.java:70)
	at
org.netbeans.modules.j2ee.metadata.model.api.support.annotation.AnnotationModelHelper.runCallable(AnnotationModelHelper.java:225)
	at
org.netbeans.modules.j2ee.metadata.model.api.support.annotation.AnnotationModelHelper.access$100(AnnotationModelHelper.java:60)
	at
org.netbeans.modules.j2ee.metadata.model.api.support.annotation.AnnotationModelHelper$2.run(AnnotationModelHelper.java:161)
	at
org.netbeans.modules.j2ee.metadata.model.api.support.annotation.AnnotationModelHelper$2.run(AnnotationModelHelper.java:163)
Comment 3 Milan Kuchtiak 2007-09-18 09:32:55 UTC
Can be fixed for Beta2.
Comment 4 Lukas Jungmann 2007-09-18 11:09:32 UTC
already fixed in trunk

*** This issue has been marked as a duplicate of 114391 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo