Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 114462 - Resource file doesn't support UTF-8?
Resource file doesn't support UTF-8?
Status: RESOLVED WORKSFORME
Product: utilities
Classification: Unclassified
Component: Properties
6.x
All All
: P3 (vote)
: TBD
Assigned To: Marian Petras
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 04:36 UTC by alexhy
Modified: 2007-11-29 09:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexhy 2007-09-03 04:36:57 UTC
My resource file contain some UTF-8 txt config file,if I open it by netbean6.0M10,show in incorrect encoding,wish fix 
this problem.
Comment 1 Lukas Hasik 2007-09-25 10:35:15 UTC
IMO, it was fixed together with issue 113945. Adame, could you evaluate it, please?
Comment 2 Adam Sotona 2007-10-05 10:52:58 UTC
Actually Mobility is not responsible for opening and editing text files. This is a general functionality in the IDE.
Lukas, do you know who could be responsible for this?
Comment 3 Vitezslav Stejskal 2007-10-08 11:35:10 UTC
What is the encoding for the project that contains the resource file? Perhaps this is just a configuration problem.
Comment 4 Marian Petras 2007-10-08 12:37:30 UTC
All .properties files are decoded/encoded using the ISO-8859-1 (Latin-1) encoding, as specified in
java.util.Properties.load(...) (see
http://java.sun.com/j2se/1.5.0/docs/api/java/util/Properties.html#load%28java.io.InputStream%29). There is a request for
enhancement filed that other encodings should be supported, too (see issue #75906 - "Add support for other encodings
(other than ISO-8859-1)"). I see this as a duplicate of this request for enhancement.

*** This issue has been marked as a duplicate of 75906 ***
Comment 5 Lukas Hasik 2007-10-09 09:07:33 UTC
I'm reopening the issue to get following informations from Alexhy - the reporter of the problem. It isn't obvious from
the report that he is using .properties file.

Alexhy:
1, could you attach the file that has the problem?
2, if you could provide a sample project demonstrating the problem it might help as well. In this way we can see all
your setting (project, file etc.)
3, what is locale on your machine?

thank you
Comment 6 Peter Pis 2007-11-29 09:17:42 UTC
No further information provided. Closing as "WORKSFORME". In a case you will encounter the issue again, please feel free
and reopen it with detailed description.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo