Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 114389 - Support for Modules Owned By Multiple Suites
Support for Modules Owned By Multiple Suites
Status: RESOLVED DUPLICATE of bug 83088
Product: apisupport
Classification: Unclassified
Component: Harness
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 15:38 UTC by tomwheeler
Modified: 2007-08-31 15:41 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomwheeler 2007-08-31 15:38:03 UTC
This has been brought up on the dev@openide mailing list many times, most recently by several people in the "Please give
feedback on your NB platform experiences" thread.

It is often desirable to create multiple versions of a given application with varying features, achieved by the
inclusion of different sets of modules.  For example, my "enterprise" suite creates a version containing modules A, B, C
and D while the "lite" suite creates a version with only A and D.  In other cases, you might have totally separate
applications which have some number of modules in common.  

The NetBeans 5.0+ harness does not directly support this, as the module must be owned by exactly one suite via the
nbproject/suite.properties file.  Developers have come up with various workarounds, but since this is a somewhat common
need, it should be handled in the default harness.

Suite chaining is one workaround.  I have been using another, which is to make all my modules refer to a static suite
name.  All my modules point to a suite named "suite" and I check a suite out from CVS like "cvs co -d suite
myactualsuitename".  

IIRC, the pre-5.0 cluster build harness did not require modules to link to the suite (or whatever the equivalent of a
suite was called).
Comment 1 Jesse Glick 2007-08-31 15:41:01 UTC
A priority if work ever resumes on apisupport.

*** This issue has been marked as a duplicate of 83088 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo