Bug 113389 - Runtime exception on executing XSLT Bridge service test
Runtime exception on executing XSLT Bridge service test
Status: RESOLVED WONTFIX
Product: soa
Classification: Unclassified
Component: XSLT
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vitaly Bychkov
issues@soa
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 17:11 UTC by kozlov
Modified: 2007-11-01 12:46 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Exception (6.68 KB, application/octet-stream)
2007-08-24 13:42 UTC, kozlov
Details
used projects (106.46 KB, application/x-compressed)
2007-08-28 15:39 UTC, Vitaly Bychkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kozlov 2007-08-21 17:11:09 UTC
Reproduced in build070815.

Steps to reproduce:

- create XSLT service;
- create XSL bridge service
- deploy services on server;
- create test for bridge service;
- run test.

Server returns exception.
Comment 1 Alexey Yarmolenko 2007-08-21 18:26:16 UTC
Please provide exception log from server and the project you are trying to deploy. Also please ensure that deployment
process completed without errors or warnings.
Comment 2 kozlov 2007-08-24 13:39:28 UTC
Same exception is thrown in case of filter one way as well as in case of filter request reply.

Exception is attached. 
Comment 3 kozlov 2007-08-24 13:40:17 UTC
-

Comment 4 kozlov 2007-08-24 13:42:05 UTC
Created attachment 47307 [details]
Exception
Comment 5 Alexey Yarmolenko 2007-08-28 10:50:28 UTC
Vitaliy, please take a look on this bug. Docs team asked to fix it with higher priority because it prevents them from
running some tutorials
Comment 6 Vitaly Bychkov 2007-08-28 15:37:01 UTC
There is an Exception in server log:
____________________________________________________________
[#|2007-08-28T18:22:21.531+0400|INFO|sun-appserver9.1|com.sun.jbi.management|_ThreadID=26;_ThreadName=httpWorkerThread-4848-1;|Starting
service assembly CompositeAppFRR on target server.|#]

[#|2007-08-28T18:22:21.687+0400|INFO|sun-appserver9.1|sun-xslt-engine.com.sun.jbi.component.lifecycle.impl.DefaultServiceUnitManager|_ThreadID=29;_ThreadName=CompositeAppFRR-XsltModuleFRR;|Initializing
SU "CompositeAppFRR-XsltModuleFRR" at root path:
C:\Sun\glassfish-v2-b58c\domains\domain1\jbi\service-assemblies\CompositeAppFRR\CompositeAppFRR-XsltModuleFRR\sun-xslt-engine|#]

[#|2007-08-28T18:22:21.734+0400|INFO|sun-appserver9.1|sun-xslt-engine.com.sun.jbi.component.lifecycle.impl.DefaultServiceUnitManager|_ThreadID=29;_ThreadName=CompositeAppFRR-XsltModuleFRR;|Endpoint
activated:         Endpoint Type: Internal
          Owner:     sun-xslt-engine  Active: True
          Service:   {http://j2ee.netbeans.org/wsdl/WSDL-FRR}WSDL-FRR1
          Endpoint:  WSDL-FRRPortTypeRole
|#]

[#|2007-08-28T18:22:21.734+0400|SEVERE|sun-appserver9.1|sun-xslt-engine.com.sun.jbi.component.lifecycle.impl.DefaultServiceUnitManager|_ThreadID=29;_ThreadName=CompositeAppFRR-XsltModuleFRR;_RequestID=e263f198-9757-4414-ad2c-36fc36d19ed0;|Service
unit "CompositeAppFRR-XsltModuleFRR" init failed: null
java.lang.NullPointerException
        at com.sun.jbi.engine.xslt.endpoint.XsltseEndpointManager.createEndpoint(XsltseEndpointManager.java:106)
        at com.sun.jbi.component.lifecycle.impl.AbstractServiceUnitManager.init(AbstractServiceUnitManager.java:171)
        at com.sun.jbi.framework.ServiceUnitOperation.process(ServiceUnitOperation.java:167)
        at com.sun.jbi.framework.Operation.run(Operation.java:104)
        at java.lang.Thread.run(Thread.java:619)
|#]

[#|2007-08-28T18:22:21.750+0400|INFO|sun-appserver9.1|sun-xslt-engine.com.sun.jbi.component.lifecycle.impl.DefaultServiceUnitManager|_ThreadID=29;_ThreadName=CompositeAppFRR-XsltModuleFRR;|Deactivating
endpoint during rollback:
EndpointInfo[name=WSDL-FRRPortTypeRole,interface={http://j2ee.netbeans.org/wsdl/WSDL-FRR}WSDL-FRRPortType,service={http://j2ee.netbeans.org/wsdl/WSDL-FRR}WSDL-FRR1,provides]|#]
____________________________________________________________

Kevan could you please look at it.
The generated jbi.xml and other service unit artifacts looks good for me. (The used projects are in attachment)
Comment 7 Vitaly Bychkov 2007-08-28 15:39:20 UTC
Created attachment 47629 [details]
used projects
Comment 8 Andrei Chistiakov 2007-09-06 16:11:47 UTC
Marking this issue to include in NB 6.0 Beta 1 release notes.
Comment 9 Joseph Silber 2007-09-10 13:58:36 UTC
release note added beta 1
Comment 10 Sergey Lunegov 2007-11-01 12:46:28 UTC
Since we don't change runtimes in FCS timeframe the issue will not be fixed.
It will be part of Release Notes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo