Bug 11257 - JSP execution in Webmodules often doesn't work.
JSP execution in Webmodules often doesn't work.
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Code
3.x
PC All
: P1 (vote)
: TBD
Assigned To: Petr Jiricka
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-10 14:29 UTC by Marek Fukala
Modified: 2003-07-02 08:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
The page displayed in browser (also contains the exception). (3.29 KB, text/html)
2001-04-10 14:31 UTC, Marek Fukala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2001-04-10 14:29:22 UTC
[20010410-0535, win2000, jdk1.3]
When you try to compile a JSP page inside a webmodule, the compilation very 
often fails and http error 500 is displayed in browser together with an 
exception (attached).
I'm not able to exactly reproduce the bug, it seems to depends on some strange 
curcumstances.
Comment 1 Marek Fukala 2001-04-10 14:31:33 UTC
Created attachment 1067 [details]
The page displayed in browser (also contains the exception).
Comment 2 Marek Fukala 2001-04-10 14:49:18 UTC
The compilation "seems to work". If you only compile a JSP page neither error 
nor exception is displaed, but when you try to execute the JSP file, web browser 
shows the exception from attachement.
Comment 3 Marek Fukala 2001-04-10 14:51:06 UTC
In the first paragraph there should be of course "when you try to execute ..."
Comment 4 L Martinek 2001-05-02 17:06:26 UTC
bug doesn't appear any more
Comment 5 L Martinek 2001-05-03 11:44:12 UTC
Oops, this bug appeared to me again.
The exception in browser says that the class _0002faaa_0002ejspaaa_jsp_0 can't 
be loaded. And actually I didn't find this class.
Directory <forte_user>\jspwork\Tomcat+3.2\207d9f5d contain these files:
_0002faaa_0002ejspaaa_jsp_0.java
_0002faaa_0002ejspaaa_jsp_1.java
_0002faaa_0002ejspaaa_jsp_2.java
_0002faaa_0002ejspaaa.class
Comment 6 Petr Jiricka 2001-05-06 13:31:11 UTC
The fact that file _0002faaa_0002ejspaaa_jsp_0.class does not exist is not 
significant, because Tomcat's classloader uses a file name which is different 
from the actual class name.

I have't been able to reproduce this, so marking as "worksforme".
Comment 7 Petr Jiricka 2001-05-07 19:54:13 UTC
Still appears.
Comment 8 Petr Jiricka 2001-05-11 14:31:47 UTC
IN=1869, fixed on May 11, 2001 by making sure that the Tomcat config file is 
written out by the IDE before Tomcat reads it.
Comment 9 L Martinek 2001-05-11 17:40:49 UTC
Still apears in continuous build 20010511-1625.
Comment 10 Petr Jiricka 2001-05-15 18:28:41 UTC
Fixed on 15-May-2001
Comment 11 L Martinek 2001-05-16 12:59:55 UTC
verified in 010515
Comment 12 Quality Engineering 2003-07-02 08:27:22 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo