Bug 111063 - Support JSR 269 (annotation processors)
Support JSR 269 (annotation processors)
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 with 3 votes (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
plan60
: UMBRELLA
: 111062 (view as bug list)
Depends on: 111065 111080
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 09:59 UTC by brucechapman
Modified: 2011-10-19 15:27 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brucechapman 2007-07-26 09:59:10 UTC
Add and Improve Support for JSR-269 Annotation Processors in java projects
Comment 1 brucechapman 2007-07-26 10:03:23 UTC
Dependent Issues add or improve support for annotation processors.

Changes are needed because Annotation processors can generate intermediate *.java files which must be treated as source
by some aspects of the project, and as intermediate files by other aspects of the project. 
Comment 2 Jesse Glick 2007-07-26 16:14:08 UTC
*** Issue 111062 has been marked as a duplicate of this issue. ***
Comment 3 Jesse Glick 2011-03-16 15:50:40 UTC
Shouldn't this be FIXED?
Comment 4 brucechapman 2011-03-18 04:23:27 UTC
This stuff is now 'good enough' in 7. Close these bugs and we can create new ones for the minor nits that still exist.

Bruce
Comment 5 Jesse Glick 2011-10-19 15:27:29 UTC
Closing; essentially implemented.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo