Bug 110686 - Enable quick search in OutlineView
Enable quick search in OutlineView
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All All
: P2 with 1 vote (vote)
: 7.2
Assigned To: Martin Entlicher
issues@platform
: PLAN
: 194716 (view as bug list)
Depends on: 208794
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 09:18 UTC by tomzi
Modified: 2013-01-16 11:53 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2007-07-24 09:18:04 UTC
In the 'Browse Repository Folders' popup (eg. Search history/Browse...) it would be helpful to have a quick search box
that filters the Repository folder. So if I type 'open' in the box it only shows the repository that contains 'open'
while I type.
Comment 1 novakm 2007-09-26 16:40:35 UTC
Increasing to P2 as it would be really helpful. It is implemented in CVS so it should be in SVN too to be consistent.
Comment 2 rbalada 2008-04-22 13:44:05 UTC
Quick search feature is originally implemented in TreeView, which is an ancestor of TreeTableView. Unfortunately
TreeTableView seems to disable this feature, possibly by empty override of initializeTree() method.

Reassigning to Tree Table View
Comment 3 Martin Entlicher 2011-12-08 15:15:28 UTC
Scheduling for 7.2. OutlineView is a successor of TreeTableView.
Comment 4 Martin Entlicher 2012-02-06 15:42:47 UTC
I've submitted an associated issue for TTV: #208098.
Comment 5 Martin Entlicher 2012-02-16 15:08:17 UTC
Implemented by changeset:   213195:8d734b0ca5dd
http://hg.netbeans.org/main/rev/8d734b0ca5dd
Comment 6 Quality Engineering 2012-02-17 11:01:49 UTC
Integrated into 'main-golden', will be available in build *201202170400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8d734b0ca5dd
User: mentlicher@netbeans.org
Log: #110686, #208098 Quick search feature implemented for TreeTableView and OutlineView.
Comment 7 markiewb 2013-01-16 11:53:16 UTC
*** Bug 194716 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo