Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 110459 - don't ask for confirmation to kill a running task
don't ask for confirmation to kill a running task
Status: RESOLVED DUPLICATE of bug 113744
Product: platform
Classification: Unclassified
Component: Progress
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
: UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 17:55 UTC by jamespb
Modified: 2008-12-22 13:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jamespb 2007-07-20 17:55:26 UTC
Start a test, hit the cancel box in the bottom right hand corner.  I get a dialog box asking me if I really did want to
cancel the running test.  Yes, I do, that's why I hit the cancel button.

At the very least give me a selection that says "never show me this dialog again."
Comment 1 Martin Krauskopf 2007-09-20 16:21:13 UTC
This is provided/handled by general Output Window 'infrastructure'. It would be nice to have "Never show again" checkbox
available. Reassigning.
Comment 2 Milos Kleint 2007-09-24 08:59:41 UTC
mkrauskopf: not really true. The OW only shows the buttons, but the actions that perform something afterwards are from
client code (thus the message is coming from your ruby code I suppose.
Comment 3 Martin Krauskopf 2007-09-24 09:19:27 UTC
tunning component: core/progress as I was told
Comment 4 Milos Kleint 2007-09-24 09:43:18 UTC

*** This issue has been marked as a duplicate of 113744 ***
Comment 5 Martin Krauskopf 2007-09-24 10:00:00 UTC
How this is related to issue 113744 which is about message? This is about the confirmation and the chance to not show
dialog at all once something like "Never show me this dialog again" is selected.
But rather RFE I think, up to you.
Comment 6 Martin Krauskopf 2007-09-24 10:31:06 UTC
I spoke with Milos and we that this issue will be solved together with an API enhancement 113744 which was renamed to:

  "Ability to provide custom action for controlling task cancellation"

So we (an others) will be able provide whole custom dialog or nothing at all.

*** This issue has been marked as a duplicate of 113744 ***
Comment 7 Torbjorn Norbye 2007-09-24 21:38:36 UTC
I'm not sure adding an API for custom termination interaction is the best way to do it. 

Whether or not a user program should be killable without interaction is not an attribute of the technology, it's an
attribute of the developer type.

Put another way, there are Java developers who want to be able to terminate their running program / test without
interaction, just as there are Ruby developers who may want the confirmation dialog.

Putting this logic into specific task handlers will just encourage different behavior in places where the difference
doesn't make sense.  Instead, whoever is posting the "Are you sure?" dialog today needs to add a checkbox to suppress
show-in-future, and persist the state. 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo