Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 109831 - Patch for: Show conditions in annotation tooltip of conditional breakpoint
Patch for: Show conditions in annotation tooltip of conditional breakpoint
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
PC Windows XP
: P3 with 2 votes (vote)
: 7.4
Assigned To: Martin Entlicher
issues@debugger
: PATCH_AVAILABLE
: 90878 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 16:08 UTC by matthies
Modified: 2013-07-15 16:00 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed patch including test (4.72 KB, patch)
2012-10-17 17:09 UTC, markiewb
Details | Diff
Patch in action (4.44 KB, image/png)
2012-10-17 17:10 UTC, markiewb
Details
Proposed patch (this time the test is really included) (14.20 KB, patch)
2012-10-17 17:19 UTC, markiewb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description matthies 2007-07-16 16:08:55 UTC
It would be great if, for conditional breakpoints, the tooltip of the breakpoint annotation symbol would display the 
condition, instead of just saying "Conditional Breakpoint".

(Also I believe there should be three dots after "Breakpoint" -> "Customize".)
Comment 1 Martin Entlicher 2007-07-17 10:37:55 UTC
This is a nice idea for the next release, thanks.
Comment 2 Petr Cyhelsky 2008-04-17 16:16:55 UTC
*** Issue 90878 has been marked as a duplicate of this issue. ***
Comment 3 280Z28 2011-10-10 17:14:19 UTC
I believe it should also show which threads will be stopped when the breakpoint is hit.
Comment 4 markiewb 2012-10-17 17:04:45 UTC
(In reply to comment #3)
> I believe it should also show which threads will be stopped when the breakpoint
> is hit.

I isolated this very specific RFE into http://netbeans.org/bugzilla/show_bug.cgi?id=220313
Comment 5 markiewb 2012-10-17 17:09:51 UTC
Created attachment 126099 [details]
Proposed patch including test

I like to contribute a patch for this issue.

The patch adds support for showing the hitcount and "codecondition"-conditions in the tooltip. See screenshot.

@NetBeans-Devs: Please review, discuss and commit! Thank you
Comment 6 markiewb 2012-10-17 17:10:35 UTC
Created attachment 126100 [details]
Patch in action
Comment 7 markiewb 2012-10-17 17:19:57 UTC
Created attachment 126103 [details]
Proposed patch (this time the test is really included)
Comment 8 Jiri Kovalsky 2012-10-19 09:36:16 UTC
Martin, can you please take a look at this patch? Thanks!
Comment 9 markiewb 2012-12-17 18:52:57 UTC
Set target-milestone of open issue to TBD (was < 7.3, f.e. 6.8), so the issue doesn't get lost.
Comment 10 markiewb 2012-12-17 19:00:32 UTC
Set target-milestone of open issue to TBD (was < 7.3, f.e. 6.8), so the issue
doesn't get lost. This time the target milestone is really set.
Comment 11 Martin Entlicher 2013-03-26 07:58:45 UTC
Thanks for the patch.
I've pushed slightly modified version, where I tried to make it better translatable:

changeset:   249484:2bb02f1ef298
http://hg.netbeans.org/core-main/rev/2bb02f1ef298
Comment 12 Jiri Kovalsky 2013-07-15 16:00:17 UTC
Product Version: NetBeans IDE Dev (Build 201306191709)
Updates: Updates available
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/dev
Cache directory: /home/cesilko/.cache/netbeans/dev


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo