Bug 109427 - Undocked windows are not persistent when switching desktops.
Undocked windows are not persistent when switching desktops.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 21:33 UTC by jdeppe
Modified: 2008-12-22 13:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdeppe 2007-07-11 21:33:53 UTC
Using NB6M10 on kubuntu 7.04 (KDE) the following occurs:

I undock an editor window
By using the window menu options I move the undocked window to another desktop (On the pager applet I see it appear on
the other desktop)
I switch to the corresponding desktop and the undocked window immediately jumps back to the desktop on which the main NB
app was running.
Comment 1 David Simonek 2007-09-17 15:10:56 UTC
Reproduced on Ubuntu 7.04 Linux, gnome, metacity WM. Interestingly, when using Beryl WM, everything is in order. WIll
have to figure out if this is Netbeans related or Swing/JDK related...
Comment 2 David Simonek 2007-10-09 15:55:02 UTC
fixed in main trunk:

Checking in home/dafe/Prace/Sources/MainTrunk/core/windows/src/org/netbeans/core/windows/Constants.java;
/cvs/core/windows/src/org/netbeans/core/windows/Constants.java,v  <--  Constants.java
new revision: 1.23; previous revision: 1.22
done
Checking in home/dafe/Prace/Sources/MainTrunk/core/windows/src/org/netbeans/core/windows/view/ViewHierarchy.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/ViewHierarchy.java,v  <--  ViewHierarchy.java
new revision: 1.50; previous revision: 1.49
done
Checking in
home/dafe/Prace/Sources/MainTrunk/core/windows/src/org/netbeans/core/windows/view/ui/DefaultSeparateContainer.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/ui/DefaultSeparateContainer.java,v  <--  DefaultSeparateContainer.java
new revision: 1.20; previous revision: 1.19
done
Checking in media/sda5/Prace/Sources/MainTrunk/openide/windows/manifest.mf;
/cvs/openide/windows/manifest.mf,v  <--  manifest.mf
new revision: 1.18; previous revision: 1.17
done
Checking in media/sda5/Prace/Sources/MainTrunk/openide/windows/apichanges.xml;
/cvs/openide/windows/apichanges.xml,v  <--  apichanges.xml
new revision: 1.21; previous revision: 1.20
done

background: this bug was triggered by netbeans 'automatic iconification' feature which iconified all separate frames
when main window was iconified by user. However, window managers like Metacity WM iconifies window when it is moved to
another virtual desktop. These two behaviors are in fight and Netbeans can never win.

Solution - I disabled automatic iconification by default, it's now available when running netbeans with
-J-Dnetbeans.winsys.auto_iconify=true (system will then suffer from this bug, of course). Disabling automatic
iconification seems to be OK, as it is remnant of ancient SDI mode. Now it seems to be logical to have undocked editors
independent.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo