Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 108480 - [push down field] PushDown field returns an erroneous message
[push down field] PushDown field returns an erroneous message
Status: RESOLVED DUPLICATE of bug 108482
Product: editor
Classification: Unclassified
Component: Refactoring
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: issues@java
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 00:35 UTC by kely_garcia
Modified: 2007-06-29 11:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kely_garcia 2007-06-29 00:35:24 UTC
Build ID: Netbeans 6.0 M9 (070502)

Steps To Reproduce:
Push down field f on the following returns an erroneous warning message: "Cannot push down any members. The selected 
type has no subtypes". 

public class A {
  int f=10;
}
class B extends A {
  int g=new A().f;
}
Comment 1 Jan Becicka 2007-06-29 11:11:50 UTC

*** This issue has been marked as a duplicate of 108482 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo