Bug 105104 - Patch for: Problems with resizing of Install wizard at license agreement step
Patch for: Problems with resizing of Install wizard at license agreement step
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P4 (vote)
: 8.0
Assigned To: Jiri Rechtacek
au-issues
: NETFIX, PATCH_AVAILABLE
: 163363 179865 (view as bug list)
Depends on:
Blocks: 165144
  Show dependency treegraph
 
Reported: 2007-05-30 09:48 UTC by Jaromir Uhrik
Modified: 2013-11-22 02:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Wizard with original size... (55.61 KB, image/png)
2007-05-30 09:50 UTC, Jaromir Uhrik
Details
Stretched wizard... (58.52 KB, image/png)
2007-05-30 09:55 UTC, Jaromir Uhrik
Details
Shrinked wizard-component right side is not visible (55.42 KB, image/png)
2007-05-30 09:57 UTC, Jaromir Uhrik
Details
Proposed patch (9.16 KB, patch)
2013-08-25 13:22 UTC, markiewb
Details | Diff
Patch in action (89.30 KB, image/png)
2013-08-25 13:22 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2007-05-30 09:48:23 UTC
NetBeans IDE Dev (Build 200705291800)
1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-87
Mac OS X version 10.4.9 running on i386
en_US (nb); MacRoman

When the Installer is in License Agreement step the resizing is not working
properly. When the installer is stretched and schrinked to its original width
then sight parts of some components are out of the wizard area. See attached
screenshots...
Comment 1 Jaromir Uhrik 2007-05-30 09:50:09 UTC
Created attachment 42938 [details]
Wizard with original size...
Comment 2 Jaromir Uhrik 2007-05-30 09:55:18 UTC
Created attachment 42939 [details]
Stretched wizard...
Comment 3 Jaromir Uhrik 2007-05-30 09:57:39 UTC
Created attachment 42940 [details]
Shrinked wizard-component right side is not visible
Comment 4 Antonin Nebuzelsky 2008-11-14 15:33:15 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 5 dlipin 2009-05-21 16:04:58 UTC
*** Issue 163363 has been marked as a duplicate of this issue. ***
Comment 6 dlipin 2010-01-26 05:42:12 UTC
*** Bug 179865 has been marked as a duplicate of this bug. ***
Comment 7 Michael Nazarov 2010-01-26 05:43:58 UTC
Seems to be old enough to be fixed... :)
Comment 8 markiewb 2013-08-25 13:22:36 UTC
Created attachment 139206 [details]
Proposed patch

I like to propose a patch to solve the issue. Please review, try it and commit. Thank you.

The patch replaces the JTextArea with a JTextPane. This way the resizing works correctly and the textflow is still supported because JTextPane also supports linewrapping.
Comment 9 markiewb 2013-08-25 13:22:56 UTC
Created attachment 139207 [details]
Patch in action
Comment 10 Jiri Rechtacek 2013-08-26 10:14:46 UTC
Benno, thanks for the patch. We are now in the finishing phase of upcoming release. In this stage we have restriction for fixing/applying patches excepting urgent issues. I will apply your for the next release. Thanks again
Comment 11 Jiri Rechtacek 2013-11-21 11:21:38 UTC
The patch was applied - http://hg.netbeans.org/core-main/rev/e0df39ccee25
Thanks
Comment 12 Quality Engineering 2013-11-22 02:44:30 UTC
Integrated into 'main-silver', will be available in build *201311220002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e0df39ccee25
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #105104 - Patch for: Problems with resizing of Install wizard at license agreement step;
applied markiewb's patch. thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo