Bug 105056 - I18N - File Upload Component does not resize to show Browse label
I18N - File Upload Component does not resize to show Browse label
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
All All
: P2 (vote)
: TBD
Assigned To: Pegah Sarram
issues@obsolete
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 18:15 UTC by kaa
Modified: 2007-07-18 01:04 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
browse (55.03 KB, image/jpeg)
2007-05-29 18:16 UTC, kaa
Details
File upload with larger font size (181.10 KB, application/octet-stream)
2007-07-17 16:20 UTC, Pegah Sarram
Details
npe (59.45 KB, image/jpeg)
2007-07-17 16:35 UTC, kaa
Details
pseudo localized jars from Ken (78.28 KB, application/octet-stream)
2007-07-17 22:30 UTC, Pegah Sarram
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2007-05-29 18:15:45 UTC
build 0525

1. Create Web App with Visual Web JavaServer Faces
2. Open Design View
3. Drag and Drop 'File Upload' component from the Palette (Basic)

Look at the 'Browse' button. It does not resize to show its label.

Assumption is that user does not need to manually resize most windows or dialogs
to see all of the ui objects and information in them. I'am running in pseudo
localized locale in which each message/label is a bit longer than english to
account for that in some locales, translations result in longer strings than in
english. Also am running at fontsize 16, which is viewed as a valid font size
that might be used. Resizing issues are not just related to i18n; they might
show to user in english locale if they run at larger fontsize.
Comment 1 kaa 2007-05-29 18:16:41 UTC
Created attachment 42909 [details]
browse
Comment 2 Jayashri Visvanathan 2007-07-16 19:56:07 UTC
Ken, is this for a Java EE 5 project or J2EE 1.4 project or both ?
Comment 3 Pegah Sarram 2007-07-17 16:19:19 UTC
If I understand it right, the issue is that the "Browse" button doesn't show its text in full when a locale other than
English is used? I tried to reproduce this with a bigger font size in English locale, but the Browse label was shown
right. See the attachment.

Could you send me your pseudo localized jars so I can reproduce the problem?
Comment 4 Pegah Sarram 2007-07-17 16:20:42 UTC
Created attachment 45223 [details]
File upload with larger font size
Comment 5 kaa 2007-07-17 16:34:29 UTC
This issue doesn't depend on jdk version. Exists with 1.5 1.4 1.3
Also I noticed an npe on Solaris 10 while reproducing it.
Comment 6 kaa 2007-07-17 16:35:24 UTC
Created attachment 45230 [details]
npe
Comment 7 Ken Frank 2007-07-17 16:41:49 UTC
Andrey,

I wrote Pegah separately wrt to sending the pseudo jar file.

as to the npe, I have seen it on solaris a lot when dropping any components, so i dont think
its just this component.

it seems to work in any case but please go thru the usual debug process to see if its en or just ja/pseudo
and file issue depending on that.

Thanks - Ken

ken.frank@sun.com
Comment 8 Pegah Sarram 2007-07-17 22:30:20 UTC
Created attachment 45261 [details]
pseudo localized jars from Ken
Comment 9 Pegah Sarram 2007-07-18 01:03:51 UTC
I don't believe the font size or window size is really an issue here. After some email exchange with Ken, I finally
understand what this issue is really about.

Ken's concern is that the 3 dots in the (Japanese) localized label could mean one of the following:

1) If you press this button, another widget will appear.
2) I don't have room to show you all my text, and I'm not set up to resize myself, so I will show you what I can
followed by 3 dots"

The English label is "Browse..." where the 3 dots mean the scenario #1. So the 3 dots in the localized label should mean
the same. 

Unfortunately, I don't know Japanese. So Ken needs to have some one in his group to verify what the translated label
say. For now, I assume the 3 dots in the localized label mean the same as in English and mark this as invalid.

BTW, We don't have control over that label at runtime, as that's handled by the browser.



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo