Bug 104367 - Variables show up as comments
Variables show up as comments
Status: RESOLVED INVALID
Product: ruby
Classification: Unclassified
Component: Code
6.x
All Windows Vista
: P3 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-20 19:02 UTC by demisone
Modified: 2007-07-03 14:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
snapshot of event (170.90 KB, image/jpeg)
2007-05-20 19:03 UTC, demisone
Details

Note You need to log in before you can comment on or make changes to this bug.
Description demisone 2007-05-20 19:02:13 UTC
I noticed this while creating a RoR project from existing code. I use the M9
with the default setup for ruby with the only change the UTF-8 support (as shown
in the Wiki).

You can see a snapshot here:
http://www.uop.gr/~nikosd/netbeans_M9_ror_variables_error.jpg

Please let me know if you want further details that would help
Comment 1 demisone 2007-05-20 19:03:47 UTC
Created attachment 42577 [details]
snapshot of event
Comment 2 Torbjorn Norbye 2007-05-21 01:09:08 UTC
This is supposed to be a cool feature - the IDE is showing you that these variables are unused. This is 
similar to the Java support where unused import and variables are also shown in gray.

Do you have suggestions for how this could be made more obvious? In my own color customizations I 
change these to be red. I also thought of using strikethrough?
Comment 3 demisone 2007-05-21 08:56:19 UTC
wow! you've got to be kidding!!! I never thought of that - this is cool :)

As for how it could be made to be more obvious, i don't know - what about
something like (css code here): {border-bottom: 1px dashed} and some explanation
when you place the mouse pointer over the variable. Maybe this clear some things
up for new users (the rest already know this feature i imagine :) )

Sorry for posting it as a bug - i just thought that it had something to do with
some kind of wrong code parsing and wanted to let you know.
Comment 4 Torbjorn Norbye 2007-05-21 17:19:40 UTC
Don't be sorry you filed it - the fact that it wasn't obvious is good feedback. Turns out there is some work 
in progress of coming up with a good color scheme, including for the "semantic syntax highlighting" 
colors, and one of the things being considered is doing underlines for things that may need the user's 
attention. I'll close this as not a bug, but the color situation will improve.

And please don't hesitate to file other things you see - getting too much feedback is better than too little. 
It's easy to close things that are duplicates or misunderstood features - and the best part about 
misunderstood features is that it tells us there's still a usability problem there.
Comment 5 Jiri Kovalsky 2007-07-03 14:09:34 UTC
Reassigning this issue to newly created 'ruby' component.
Comment 6 Jiri Kovalsky 2007-07-03 14:41:42 UTC
Changing target milestone of all resolved Ruby issues from TBD to 6.0 Beta 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo