Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 103103 - Side bar diff indicates modifications after Rollback.
Side bar diff indicates modifications after Rollback.
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 10:34 UTC by Peter Pis
Modified: 2008-01-03 09:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (667 bytes, patch)
2007-05-03 15:07 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2007-05-02 10:34:17 UTC
NetBeans IDE 6.0 Preview (M9, build 070501)
1.6.0-rc; Java HotSpot(TM) Client VM 1.6.0-rc-b101
Windows XP version 5.1 running on x86
en_GB (nb); Cp1252

Steps:
1. Create new project, select project root and invoke "Versioning | Mercurial |
Initialize" action.
2. Select project root and invoke "Mercurial | Status" action on it.
3. Modify (Remove some lines) and save some file. Commit changes.
4. Select this file and invoke "Mercurial | Rollback". Confirm upcoming dialog.

The content of the file is correct but the side bar diff indicates the the lines
were removed while "Mercurial" ("Mercurial | Status") view is not aware of any
changes.
Comment 1 John Rice 2007-05-02 11:22:42 UTC
Unable to reproduce at the minute, but will continue to investigate.
Comment 2 Padraig Obriain 2007-05-02 12:23:08 UTC
I can reproduce this.

mercurial thinks that there is no change to the file after the rollback and
forced update and there is no difference between the file in the working
directory and
the latest version in the repository.

Comment 3 John Rice 2007-05-02 16:18:50 UTC
Need to add a refresh if the rollback effects any files in the project. Should
also resolve the test case reported in 103125.
Comment 4 Padraig Obriain 2007-05-03 15:07:04 UTC
Created attachment 42106 [details]
proposed patch
Comment 5 Padraig Obriain 2007-05-08 12:16:51 UTC
This patch has been committed.
Comment 6 Peter Pis 2007-05-16 09:17:15 UTC
Seems to work fine now. Verified. (070516)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo