Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 101517 - 5.5.1 exits abruptly during build-impl.xml manipulation
5.5.1 exits abruptly during build-impl.xml manipulation
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Code
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@javaee
release551_fixes_candidate, release55...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 08:58 UTC by Martin Grebac
Modified: 2007-06-11 22:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
core dump log (16.08 KB, text/plain)
2007-04-18 08:59 UTC, Martin Grebac
Details
Proposed patch in build-impl.xsl (28.59 KB, text/plain)
2007-04-29 19:30 UTC, Roderico Cruz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Grebac 2007-04-18 08:58:58 UTC
NB 5.5.1 core dumps in different situations. I noticed this on Solaris, but
thought it's an issue of me using daily Solaris 11 builds for development.
However, at least two more people from our team experienced this on Windows XP.
Both JDK 1.5.0_10 as well as .0_11 fail.

We didn't observe this with previous 5.5.1 builds. I experienced it during
project creation, or creation of WS client, during initial scanning, or if NB is
just left alone for a while.

Here's the core dump, and I'll attach the full dump. Filing for tracking
purposes, I'll file JDK issue as well.

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0xce307847, pid=2299, tid=82
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_11-b03 mixed mode)
# Problematic frame:
# V  [libjvm.so+0x87847]
#
# An error report file with more information is saved as hs_err_pid2299.log
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
Comment 1 Martin Grebac 2007-04-18 08:59:49 UTC
Created attachment 41137 [details]
core dump log
Comment 2 Martin Grebac 2007-04-18 09:00:26 UTC
changing platform definition
Comment 3 Marian Mirilovic 2007-04-19 07:32:43 UTC
Isn't this duplicate of issue 98942 ?
Comment 4 Martin Grebac 2007-04-19 08:52:08 UTC
Yes, I think that's it. But this is happening with 5.5.1! It's P1 for 6.0 and no
fix for 5.5.1 which has the same error? I don't get it.
Comment 5 Marian Mirilovic 2007-04-22 21:59:56 UTC
ok, reassign to web (because issue 98942 was reported/fixed there)
Comment 6 Petr Pisl 2007-04-23 11:57:55 UTC
Milan, can be connected with the ws staff?
Comment 7 Petr Blaha 2007-04-23 12:02:25 UTC
Petre, it seems that this is duplicate of issue #98942. Rico created patched jar
and I asked Martin and his colleagues to verify that the issue is resolved. Then
we will upload patch to UC or fix in NB 5.5.1 FCS in case the new build will be
required by Sun Studio.
Comment 8 Roderico Cruz 2007-04-29 19:30:41 UTC
Created attachment 41944 [details]
Proposed patch in build-impl.xsl
Comment 9 Milan Kuchtiak 2007-04-30 14:34:15 UTC
The issue was already fixed for 6.0.
The fix was already verified by original reporter.
The patch will be uploaded to update center after 5.5.1 release.
Comment 10 pgebauer 2007-05-30 13:16:38 UTC
The issue has been ported into the release551_fixes branch.

Checking in build-impl.xsl;
/cvs/web/project/src/org/netbeans/modules/web/project/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.100.12.6.2.53.6.5.4.1; previous revision: 1.100.12.6.2.53.6.5
done
Comment 11 Lukas Jungmann 2007-06-06 18:40:55 UTC
v. in patch 1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo