Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 100841 - Keyboard access problems w/ generate getter/setter dlg
Keyboard access problems w/ generate getter/setter dlg
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-12 20:10 UTC by _ tboudreau
Modified: 2016-07-07 07:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Simple patch to accept CTRL+Enter for the default button action (1009 bytes, patch)
2007-04-19 09:19 UTC, _ leonchiver
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2007-04-12 20:10:57 UTC
If you try to check the items in the generate getter/setter dlg with the
keyboard, each time you press space to select, the explorer quick search window
pops up.

Probably the right fix is for it not to be triggered by space characters -
searching for nodes whose name begins with " " seems pretty unlikely.
Comment 1 _ leonchiver 2007-04-19 09:17:20 UTC
Additional to this problem, I found another one:
in all 'Generate (some stuff)' dialogs, you can select variables, methods etc.
with the Enter key. But you can close the dialog only with the mouse.
Almost all of the NetBean's dialogs accept CTRL+Enter for the default button, so
I did fix that on my computer, and have a simple patch.   
Comment 2 _ leonchiver 2007-04-19 09:19:42 UTC
Created attachment 41224 [details]
Simple patch to accept CTRL+Enter for the default button action
Comment 3 Petr Hrebejk 2007-05-24 16:13:22 UTC
Shoud be fixed now by saubrecht
Comment 4 _ tboudreau 2007-05-24 23:29:51 UTC
Still some problems in conjunction with quick search:
Create a subclass of TreeScanner.
Alt-Insert, choose Override Methods.
Using the keyboard, arrow down and expand TreeScanner.
Type "visitId" to locate visitIdentifier.

Pressing enter should select just that method and close the dialog;  pressing
space should select that method.  What actually happens (probably because of
focus transfer from the quick search window):  Space *deselects*
visitIdentifier.  Enter closes the dialog doing nothing.
Comment 5 Jiri Prox 2007-09-17 20:34:10 UTC
Obsolete milestone, please reevaluate
Comment 6 _ tboudreau 2007-10-11 04:53:22 UTC
I'd suggest adding an API request for an actual explorer list/tree view with checkboxes, that really supports this sort of thing.  Implementing it any other way 
is going to be one or another butt-ugly hack.
Comment 7 Jan Becicka 2008-02-18 16:26:19 UTC
Dusane, please take a look at it. Should be easy to fix.
Comment 8 Geertjan Wielenga 2011-10-17 10:01:21 UTC
Reproducible in 7.1 Beta.
Comment 9 markiewb 2012-05-17 16:10:33 UTC
A workaround is the following using NetBeans IDE Dev (Build 201205090400) /7.2.

Create a subclass of TreeScanner.
Alt-Insert, choose Override Methods.
Using the keyboard, arrow down and expand TreeScanner.
Type "visitId" to locate visitIdentifier.
Press 'enter' --> quicksearch window disappears (!!! thats the trick!!!)
Press 'space' --> method gets selected
Press 'enter' --> the default action 'Generate' is invoked
Comment 10 markiewb 2012-12-17 18:52:43 UTC
Set target-milestone of open issue to TBD (was < 7.3, f.e. 6.8), so the issue doesn't get lost.
Comment 11 markiewb 2012-12-17 19:02:57 UTC
Set target-milestone of open issue to TBD (was < 7.3, f.e. 6.8), so the issue
doesn't get lost. This time the target milestone is really set.
Comment 12 Martin Balin 2016-07-07 07:18:01 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo