Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 10021 - find and replace from filesystem explorer
find and replace from filesystem explorer
Status: RESOLVED DUPLICATE of bug 18237
Product: utilities
Classification: Unclassified
Component: Search
3.x
All All
: P2 with 2 votes (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
: 20401 20670 35555 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 22:19 UTC by Simon Harris
Modified: 2005-05-03 14:23 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Harris 2001-03-06 22:19:04 UTC
It would be nice to have a find and replace (in addition to the simple find) 
mechanism from the filesystem explorer. An example of its intended use: I was 
recently asked to remove around some unecessary import statements from around 
175 files. I could find the files using the filesystem explorer. However I was 
forced to open each one and perform another find|replace 175 times!

Kawa 4.x has this feature and I sorely missed it when moving to netbeans (which 
btw is far superior in almost every other aspect).
Comment 1 Jan Chalupa 2001-05-06 15:21:20 UTC
Target milestone -> 3.3
Comment 2 Jan Chalupa 2001-11-27 17:26:28 UTC
Target milestone -> 3.3.1.
Comment 3 _ lkramolis 2002-02-11 17:30:35 UTC
Editor module already implement 'Find and Replace' functionality,
which should be also used with Find and Replace on filesystem. Editor
module should just go through filesystem and apply its F&R action on
all FileObjects.

Reasonable connection between Editor and Utilities modules could be
Find and Replace action on any DataObject (probably Tools action)
provided by Editor module. User will specify files ('Find ...' -
utilities) in which want to apply F&R action ('Tools | Find and
Replace' - editor).
Comment 4 _ lkramolis 2002-02-11 17:31:35 UTC
*** Issue 20401 has been marked as a duplicate of this issue. ***
Comment 5 _ lkramolis 2002-02-19 14:37:35 UTC
*** Issue 20670 has been marked as a duplicate of this issue. ***
Comment 6 Marek Grummich 2002-07-22 10:00:17 UTC
Set target milestone to TBD
Comment 7 Marek Grummich 2002-07-22 10:04:59 UTC
Set target milestone to TBD
Comment 8 psuk 2004-03-23 18:18:14 UTC
Changing subcomponent to "search"
Comment 9 tomzi 2004-04-01 11:53:43 UTC
We are quite often confronted with replacing text in multiple files,
not only in java source code, when renaming objects, which i hope will
be available through the long awaited upcoming refactoring tool. But
also when replacing licence information or text/code in jsp or html or
configuration files. 

At the moment i always need to use tools like UltraEdit, which is
quite uncomfortable.

Is there any support planned for this feature in the upcoming 4.0 version?
Comment 10 Marian Petras 2004-10-18 15:46:25 UTC
*** Issue 35555 has been marked as a duplicate of this issue. ***
Comment 11 Marian Petras 2004-10-18 15:48:01 UTC
Issue #35555 contains useful comments from Tim Boudreau - read them
before implementing this feature.
Comment 12 Marian Petras 2005-05-03 14:23:31 UTC
This is a duplicate of issue #18237. Bug report #18237 contains much more
comments and votes so I decided to keep it open instead of this one.

*** This issue has been marked as a duplicate of 18237 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo