Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 230532

Summary: Improve logic of showing Dependencies node
Product: projects Reporter: Tomas Danek <musilt2>
Component: MavenAssignee: Milos Kleint <mkleint>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: jkovalsky, mmirilovic, skygo
Version: 7.4   
Target Milestone: 7.4   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Tomas Danek 2013-05-30 13:22:33 UTC
...for 7.4.

Fix of bug 228780 enabled showing Dependencies node for pom project, however disabled node for newly created Java application archetype project (tracked as regression bug 230525)

For 7.4, please find some compromising approach when to show this node.
Comment 1 Tomas Danek 2013-06-14 11:52:39 UTC
Have to put this into focus; adding compile time dependency is now really pain in the ass,  assuming I want to use UI dialog for this, one has to invoke "add dependency" on "Test dependencies" node, add dependency, open pom.xml, and change dependency from "test" to "compile". 
How many Maven beginners will be able to manage such a workflow?
Comment 2 Tomas Danek 2013-06-14 13:50:24 UTC
we agreed with Marian that this is Beta stopper; suggested fix is to show node always.
Comment 3 Milos Kleint 2013-06-14 14:08:04 UTC
(In reply to comment #1)
> Have to put this into focus; adding compile time dependency is now really pain
> in the ass,  assuming I want to use UI dialog for this, one has to invoke "add
> dependency" on "Test dependencies" node, add dependency, open pom.xml, and
> change dependency from "test" to "compile". 
> How many Maven beginners will be able to manage such a workflow?

With the same twisted logic you could argue how many newbies will be able to add a Runtime dependency with the Runtime Dependencies node missing. Have we actually received a report from someone new to Maven?
Comment 4 Milos Kleint 2013-06-14 14:20:06 UTC
http://hg.netbeans.org/core-main/rev/e84b9d0a70a3
I don't care enough to argue.. dependencies node always shows now, even if empty, in all packagings..

shall it go this way to beta branch as well?
Comment 5 Tomas Danek 2013-06-14 14:32:17 UTC
yes please, put it into beta. Thanks!
(In reply to comment #4)
> http://hg.netbeans.org/core-main/rev/e84b9d0a70a3
> I don't care enough to argue.. dependencies node always shows now, even if
> empty, in all packagings..
> 
> shall it go this way to beta branch as well?
Comment 6 Milos Kleint 2013-06-14 14:39:23 UTC
http://hg.netbeans.org/releases/rev/00cc70b2226e
Comment 7 Quality Engineering 2013-06-14 21:05:13 UTC
Integrated into 'releases', will be available in build *201306141844* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/00cc70b2226e
User: Milos Kleint <mkleint@netbeans.org>
Log: #230532 always show dependencies node
Comment 8 Milos Kleint 2013-06-16 07:21:13 UTC
*** Bug 231312 has been marked as a duplicate of this bug. ***
Comment 9 Quality Engineering 2013-06-18 14:47:39 UTC
Integrated into 'main-golden', will be available in build *201306181109* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e84b9d0a70a3
User: Milos Kleint <mkleint@netbeans.org>
Log: #230532 always show dependencies node
Comment 10 Marian Mirilovic 2013-06-19 09:02:30 UTC
Milas, 
could we also integrate this into releases/release74_beta ? Would be nice to have it there today by COB. Thanks in advance
Comment 11 Milos Kleint 2013-06-19 09:13:26 UTC
(In reply to comment #10)
> Milas, 
> could we also integrate this into releases/release74_beta ? Would be nice to
> have it there today by COB. Thanks in advance

already there?
http://hg.netbeans.org/releases/rev/00cc70b2226e
Comment 12 Marian Mirilovic 2013-06-19 10:26:49 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Milas, 
> > could we also integrate this into releases/release74_beta ? Would be nice to
> > have it there today by COB. Thanks in advance
> 
> already there?
> http://hg.netbeans.org/releases/rev/00cc70b2226e

Ups, now I see .. thanks, I just checked last notification from builder was for trunk, not beta .. once again apologize for false request.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo