Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 44575

Summary: Watches - provide drag and drop of expression from editor
Product: debugger Reporter: zikmund <zikmund>
Component: CodeAssignee: Martin Entlicher <mentlicher>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: lsl239, vincesheard
Version: 4.x   
Target Milestone: 6.x   
Hardware: PC   
OS: All   
Whiteboard: DR ndc-chat MC PLAN
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on: 136658, 177506    
Bug Blocks:    

Description zikmund 2004-06-08 18:03:47 UTC
It is very usefull to mark an expression in editor
and drag it to the debug windows. It is then added
as a watch.

I think that similar feature is quite common in
other IDEs for a long time.
Comment 1 Martin Entlicher 2006-11-02 09:36:32 UTC
*** Issue 88446 has been marked as a duplicate of this issue. ***
Comment 2 _ gtzabari 2006-11-02 13:56:18 UTC
Please also add the ability to add new watches by clicking on an empty "slow" in
the watch window and typing the expression in directly. This is described in
issue 88446.
Comment 3 Martin Entlicher 2007-05-18 15:15:09 UTC
*** Issue 83737 has been marked as a duplicate of this issue. ***
Comment 4 Martin Entlicher 2007-05-21 17:06:38 UTC
We currently can not add DnD support to debugger views, because the
TreeTableView does not support it. We will add DnD support after it's supported
by the TTV.
- Adding dependency on issue #29031.

*** This issue has been marked as a duplicate of 29031 ***
Comment 5 Martin Entlicher 2007-05-21 17:08:28 UTC
Well, I did not want to set it as duplicate ;-) reopening...
Comment 6 Jiri Vagner 2007-12-13 09:48:24 UTC
Another drag and drop use case: Drag one or more local variables from huge long tree in "Local Variables" window and
drop it into "Watches" window
Comment 7 Martin Entlicher 2008-10-14 11:09:38 UTC
Can be implemented when we start using the new Outline View
Comment 8 Martin Entlicher 2008-10-14 11:10:44 UTC
*** Issue 149889 has been marked as a duplicate of this issue. ***
Comment 9 Leonid Lenyashin 2008-12-11 10:41:55 UTC
This issue is important for a partner that creates its own NB based IDE for embedded development
Comment 10 Martin Entlicher 2008-12-11 12:56:47 UTC
We actually plan to make this work into NetBeans 7.0.
We have a UI specification of improvements in Watches window at
http://wiki.netbeans.org/DebuggerVariables70#section-DebuggerVariables70-Watches

However, this still depends on the OutlineView (issue #136658), which is not in an acceptable state yet, but should be
fixed into 7.0.
Comment 11 Leonid Lenyashin 2009-03-17 14:14:44 UTC
It looks like the dependency has been fixed, so I'm curios if DnD feature is expected anytime soon?
Comment 12 Tomas Pavek 2009-05-15 17:21:05 UTC
*** Issue 154953 has been marked as a duplicate of this issue. ***
Comment 13 Tomas Pavek 2009-05-15 17:22:03 UTC
*** Issue 163636 has been marked as a duplicate of this issue. ***
Comment 14 alexey_baranov 2009-05-15 18:06:24 UTC
And do not forget to implement a simple access to the editing watches. Double click and "Insert" key will be very fine.

Thanks.
Comment 15 Martin Entlicher 2009-12-05 07:25:15 UTC
The Drag and Drop of watches was added for JPDA debugger in
changeset:   155333:24a6e62d11e8
and
changeset:   155334:000ddd04ed49

I'm working on a possibility to re-order watches via DnD and then will put DnD support into generic Watches view so that it works for all debuggers.
Comment 16 Quality Engineering 2009-12-07 03:19:59 UTC
Integrated into 'main-golden', will be available in build *200912070253* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/24a6e62d11e8
User: mentlicher@netbeans.org
Log: #44575 - Drag and Drop from/to Watches window works for JPDA debugger.
Comment 17 Martin Entlicher 2009-12-15 09:58:36 UTC
Re-ordering of watches via DnD is implemented in changeset:   155795:a51a2c023c3d
http://hg.netbeans.org/main/rev/a51a2c023c3d
Comment 18 Quality Engineering 2009-12-16 12:15:31 UTC
Integrated into 'main-golden', will be available in build *200912161400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a51a2c023c3d
User: mentlicher@netbeans.org
Log: #44575 - Drag and drop implemented for reordering also.
Comment 19 Martin Entlicher 2010-01-14 05:48:32 UTC
Finally fixed in generic Watches NodeModel in changeset:   156752:1a0a687e7af6
http://hg.netbeans.org/main/rev/1a0a687e7af6
Comment 20 Quality Engineering 2010-01-14 23:40:39 UTC
Integrated into 'main-golden', will be available in build *201001150201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1a0a687e7af6
User: mentlicher@netbeans.org
Log: #44575 - DnD of watches moved to the generic watches NodeModel. Debuggers should implement NodeModelFilter to use the generic DnD functionality.
Comment 21 Quality Engineering 2010-04-29 09:17:57 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo