Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 251308

Summary: Gluon SceneBuilder cannot be detected by NetBeans
Product: javafx Reporter: markiewb
Component: Visual Tool IntegrationAssignee: Roman Svitanic <rsvitanic>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: omniprof
Version: 8.0.2   
Target Milestone: 8.1   
Hardware: PC   
OS: Windows 7   
Whiteboard: 802patch-fixed
Issue Type: DEFECT Exception Report:

Description markiewb 2015-03-19 20:48:49 UTC
Oracle does not provide builds of scene builder since JDK8_40. Gluon provides builds instead - http://gluonhq.com/products/downloads/

ACTUAL: 
I installed the Windows version http://gluonhq.com/download/scene-builder-windows/, but NB does not find a valid scenebuilder installation there


Product Version: NetBeans IDE 8.0.2 (Build 201411181905)
Updates: NetBeans IDE is updated to version NetBeans 8.0.2 Patch 1
Java: 1.8.0_40; Java HotSpot(TM) 64-Bit Server VM 25.40-b25
Runtime: Java(TM) SE Runtime Environment 1.8.0_40-b25
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 1 markiewb 2015-03-19 21:20:15 UTC
FYI: A workaround to patch the 8.0.0 Gluon Scenebuilder to be detected by NB8.0.2.

<code>
set gluonDir=c:\Program Files (x86)\SceneBuilder
set targetDir=c:\temp\workingforNB

mkdir "%targetDir%"
mkdir "%targetDir%/bin"
mkdir "%targetDir%/app"
xcopy /E "%gluonDir%" "%targetDir%\bin"
copy "%gluonDir%\app\SceneBuilder.cfg" "%targetDir%\app\SceneBuilder.properties"
<code>
Comment 2 Roman Svitanic 2015-03-20 14:01:12 UTC
Changeset: 945b4f08488c
Author:    Roman Svitanic <rsvitanic@netbeans.org>
Date:      2015-03-20 15:00
Message:   #251308: Gluon SceneBuilder cannot be detected by NetBeans - fixed
Comment 3 Quality Engineering 2015-03-21 07:55:49 UTC
Integrated into 'main-silver', will be available in build *201503210001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/945b4f08488c
User: Roman Svitanic <rsvitanic@netbeans.org>
Log: #251308: Gluon SceneBuilder cannot be detected by NetBeans - fixed
Task #251308 - Gluon SceneBuilder cannot be detected by NetBeans
Comment 4 Roman Svitanic 2015-03-23 09:49:11 UTC
*** Bug 251364 has been marked as a duplicate of this bug. ***
Comment 5 Roman Svitanic 2015-05-28 14:45:30 UTC
Transplanted to the release801 branch:
http://hg.netbeans.org/releases/rev/9fed5d793302
Comment 6 Quality Engineering 2015-05-28 19:01:43 UTC
Integrated into 'releases/release801', will be available in build *201505281753* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/9fed5d793302
User: Roman Svitanic <rsvitanic@netbeans.org>
Log: #251308: Gluon SceneBuilder cannot be detected by NetBeans - fixed
Task #251308 - Gluon SceneBuilder cannot be detected by NetBeans
Comment 7 Lou Dasaro 2015-10-13 19:05:55 UTC
Verified FIXED using:
Product Version: NetBeans IDE 8.1 RC2 (Build 201510122201)
Java: 1.8.0_66-ea; Java HotSpot(TM) Client VM 25.66-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_66-ea-b02
System: Windows 8.1 version 6.3 running on x86; Cp1252; en_US (nb)
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo