Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 251364 - Gluon Scene Builder is not recognized by OS X and Linux as well as Windows
Gluon Scene Builder is not recognized by OS X and Linux as well as Windows
Status: RESOLVED DUPLICATE of bug 251308
Product: javafx
Classification: Unclassified
Component: Visual Tool Integration
8.1
PC All
: P3 (vote)
: TBD
Assigned To: Roman Svitanic
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-22 21:43 UTC by omniprof
Modified: 2015-03-25 10:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description omniprof 2015-03-22 21:43:20 UTC
Like the Windows problem, Gluon's distribution of Scene Builder will not integrate with NetBeans 8.02. The Windows workaround does work. I will try the workaround on Linux. The Mac OS X distribution is organized differently from Win and Linux and so I have no idea what the workaround could be.

Fedora 21 Client with Java 8u40
OS X Yosemite with Java 8u40
Windows 8.1 with Java 8u40

As the original post stated Windows only as the problem I have re-entered the issue.
Comment 1 Roman Svitanic 2015-03-23 09:49:11 UTC
This should be already fixed in dev build. Please verify on OS X. Thanks.

*** This bug has been marked as a duplicate of bug 251308 ***
Comment 2 omniprof 2015-03-25 00:58:55 UTC
I have verified that the nightly build works on Windows 8.1, OS X 10.10 and Fedora 21. 

Could you please tell me when this fix might be rolled out to current users of 8.02. I am starting a class next week that will use JavaFX and Scene Builder. My students will want to install NetBeans on their own systems and it makes the installation complicated if I have to explain nightly builds.

Thank-you.
Comment 3 Roman Svitanic 2015-03-25 10:06:58 UTC
Thanks for the verification! I have marke issue #251308 as a candidate for the next NetBeans 8.0.2 patch. Currently there is no plan for patch release in the next week, so it will not be available when your class starts.

As a temporary solution you can try:
1. use NB 8.0.2 with Scene Builder 2.0,
2. use Dev builds with Gluon Scene Builder,
3. use 8.0.2 and try workaround mentioned in issue #251308.

Thanks!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo