Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 214723

Summary: Newly created and selected Run configuration is not displayed in main toolbar
Product: javafx Reporter: Petr Somol <psomol>
Component: ProjectAssignee: Petr Somol <psomol>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: mmirilovic, tzezula
Version: 7.2   
Target Milestone: 7.4   
Hardware: PC   
OS: Windows 7   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Petr Somol 2012-06-25 15:10:21 UTC
Open FX Project Properties and in Run panel create a new configuration. Having it created, leave it selected in the combo and press OK to close Properties dialog. The new configuration should appear as selected in the main IDE toolbar, but instead only white space is displayed there.

Technically this is caused by the fact that config file change notification is not generated for single files joined in atomic file action, therefore the creation of new configuration file can be missed by ProjectConfigurationProvider.
To correct this we will need a dedicated API to notify configuration creation directly.

Note that selecting an existing configuration in Project Properties dialog is not affected at works as expected, as I just checked on code in trunk.
Comment 1 Stepan Zebra 2012-06-26 15:29:11 UTC
The configuration combobox is also empty in SE projects when WebStart is enabled...
Comment 2 Tomas Zezula 2012-06-26 16:08:25 UTC
Yes, this is the same case.
The JFX configuration handling is a copy of JWS .
The problem is that the JFX (JWS) writes a configuration as a file to disk and asks the J2SE to set it as a default configuration however the J2SE does not see the config file as the project properties save runs in an atomic action which was not yet committed, it's committed by project infrastructure after all changes were done.
Comment 3 Stepan Zebra 2012-07-11 12:53:31 UTC
Please evaluate possibility to fix this in 7.2 patch.
Comment 4 Stepan Zebra 2012-11-26 13:54:22 UTC
Workaround to make the new configuration visible in toolbar combobox is to select a different project and then select back the project with the new configuration.
Comment 5 Petr Somol 2013-06-18 14:16:03 UTC

*** This bug has been marked as a duplicate of bug 231447 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo