Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 162580

Summary: Allow indexing files that are not under GlobalPathRegistry's roots
Product: editor Reporter: Vitezslav Stejskal <vstejskal>
Component: Parsing & IndexingAssignee: Tomas Zezula <tzezula>
Status: RESOLVED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: av-nb, inonit, pjiricka, vv159170
Version: 6.xKeywords: PERFORMANCE
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on: 187282    
Bug Blocks: 162144    

Description Vitezslav Stejskal 2009-04-14 13:01:18 UTC
Some indexers like for example FileIndexer need to index all files in a project. This is currently not possible, because
indexing is based on classpath roots registered in GlobalPathRegistry. Typically projects contain source roots inside
the project folder (eg. src, test, web, etc folders), but they may contain additional files outside of these roots and
these files are basically invisible to indexers. While for most indexers this is a desirable behavior for some others
this is a problem.
Comment 1 Alexei Mokeev 2009-04-15 13:13:55 UTC
A proper fix for issue 162144 depends on this issue. For now we added some implementation for the cases when files are
not present in the index.
Comment 2 Petr Jiricka 2009-04-16 13:43:59 UTC
This ability would also be useful for addressing issue 158261 - performance of finding the hibernate config file.
Comment 3 Vladimir Voskresensky 2009-04-16 14:30:58 UTC
trying several days IDE with new impl of Go To File I can say:
it is a very pity to loose navigation into test data files (our test files are not *.java, but *.cpp/h/cc files) which I
had before in 6.5.

Is it really impossible to fix that regression in 6.7?
Comment 4 Alexei Mokeev 2009-04-16 15:11:17 UTC
Go To File should work after the fix of 162144(integrated on 04/15). Could you please check with some recent build and
report problems if any ? 
Comment 5 Vladimir Voskresensky 2009-04-16 15:17:34 UTC
great! now IDE again finds my test data files :-)
Comment 6 Petr Jiricka 2009-06-09 15:31:50 UTC
BTW, is this enhancement considered for 6.8?
Comment 7 Vitezslav Stejskal 2010-05-20 12:01:04 UTC
*** Bug 178875 has been marked as a duplicate of this bug. ***
Comment 8 Tomas Zezula 2010-11-18 17:44:22 UTC
Not a defect, it's request for feature.
Comment 9 Martin Balin 2016-07-07 07:27:19 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo