Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178875 - Freeform project should search for Task "patterns" outside compilation-unit
Freeform project should search for Task "patterns" outside compilation-unit
Status: RESOLVED DUPLICATE of bug 162580
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 13:38 UTC by inonit
Modified: 2010-05-20 12:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description inonit 2009-12-18 13:38:34 UTC
Currently, using a freeform project, using http://netbeans.org/ns/freeform-project/1.xsd, the Task List module does not scan any files outside the java-data section, so far as I can tell.

In my view, it should search all folders declared as source-folders in the folder section.  This way it would pick up @todo (etc.) notations in source files written in other languages.

If anyone else is struggling with this, I should mention that if one creates "fake" package-root elements inside a "fake" compilation unit one can get the desired behavior.  But that seems an absurd workaround.
Comment 1 Stanislav Aubrecht 2010-04-02 11:49:07 UTC
task list scans whatever files it gets from indexing infrastructure
Comment 2 Vitezslav Stejskal 2010-05-20 12:01:04 UTC

*** This bug has been marked as a duplicate of bug 162580 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo