Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 124186

Summary: Proxy Settings - Test Connection Button
Product: platform Reporter: radical_dreamer <radical_dreamer>
Component: -- Other --Assignee: Libor Fischmeistr <lfischmeistr>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P4 CC: ikar
Version: 6.xKeywords: UI
Target Milestone: 7.4   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description radical_dreamer 2007-12-18 10:31:43 UTC
In Tools --> Options --> General --> Proxy Settings, a 'test connection' button would be really useful.
Comment 1 Petr Dvorak 2008-04-22 17:09:11 UTC
This should be a simple enhancement
Comment 2 Peter Pis 2008-04-22 20:09:52 UTC
Reassigning to "core".
Comment 3 Lukas Hasik 2008-04-23 10:10:30 UTC
I don't see any reason for such button it would only complicate the UI however I'm leaving it for developer's evaluation
Comment 4 radical_dreamer 2008-12-22 13:05:11 UTC
It can be really useful when working within a network which has a proxy as the only gateway to the Internet.

The only way to check that your proxy settings are correct, is to close the 'Options' window and try to update NetBeans,
for example. In case you got the proxy settings wrong a few times, you'd have to go back to 'Options' and do this
several times.
Another way would be to try the proxy settings within a browser (which might have already different proxy settings).

Anyway, IMO, a 'test connection' button is the ideal solution. 
It would simply try to connect to the 'NetBeans' website and let the user know whether the connection was successful or not.

It's a simple feature, yet necessary.


On another note, the 'Use System Proxy Settings' should be clarified in the Help documentation.
While 'Manual proxy settings' is explained, the 'Use System Proxy Settings' has no explanation at all.
Comment 5 Libor Fischmeistr 2013-04-04 10:27:39 UTC
*** Bug 79498 has been marked as a duplicate of this bug. ***
Comment 6 Libor Fischmeistr 2013-04-04 10:30:56 UTC
Added button that allows you to test proxy settings.

Changeset: http://hg.netbeans.org/core-main/rev/067996975b47
(Complete merge of system_proxy_reload branch to trunk).
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo