Bug 96471

Summary: I18N - netbeans does not show menus or other ui objects as per locale if user in a rtl locale
Product: ide Reporter: Ken Frank <kfrank>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: kaa
Version: 6.xKeywords: I18N
Target Milestone: 6.x   
Hardware: Sun   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Ken Frank 2007-02-23 19:14:47 UTC
Please assign to correct cat/subcat.

This has come up recently with community translation for locales that have
their text read right to left - in this case its Persian but it can also be Arabic
or Hebrew and some other locales.

Part of the behavior of tools/applications is that the menu and other ui items
show from right to left, unlike the default left to right.

jdk does not by default use the value of the locale user is in to decide this
(for example, see swing issue 4505945)

however in that issue, they are saying they dont because swing/jdk is not
localized to those locales 

but for nb, it is in progress.

---> this issue is about need to provide that support in netbeans -
perhaps either by default based on locale or at least a startup argument.

NOTE - seprate issue has been filed on platform - 96333
and will be filed about form editor itself
but this is about netbeans itself.
Comment 1 Jesse Glick 2007-02-23 19:58:15 UTC
I don't think this is distinct from issue #96333. The IDE is simply a
Platform-based application and uses the same menu bar infrastructure.

*** This issue has been marked as a duplicate of 96333 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo