Bug 75885

Summary: Code Folding doesn't work for .h files
Product: cnd Reporter: _ gordonp <gordonp>
Component: -- Other --Assignee: Vladimir Voskresensky <vv159170>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 5.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard: CND-Preview-2
Issue Type: DEFECT Exception Report:

Description _ gordonp 2006-05-03 21:07:11 UTC
I've just opened 23 .h files. Only 2 of the 23 showed any code folding.
By far the most common behavior was to throw the following exception:

exception: line 79:34: unexpected char: 0xFFFF
line 79:34: unexpected char: 0xFFFF
        at
org.netbeans.modules.cnd.modelimpl.antlr.CPPFoldingLexer.nextToken(CPPFoldingLexer.java:388)
        at antlr.TokenBuffer.fill(TokenBuffer.java:69)
        at antlr.TokenBuffer.LA(TokenBuffer.java:80)
        at antlr.LLkParser.LA(LLkParser.java:52)
        at antlr.Parser.consumeUntil(Parser.java:149)
        at antlr.Parser.recover(Parser.java:312)
        at
org.netbeans.modules.cnd.modelimpl.antlr.CPPFoldingParser.declaration(CPPFoldingParser.java:335)
        at
org.netbeans.modules.cnd.modelimpl.antlr.CPPFoldingParser.translation_unit(CPPFoldingParser.java:133)
        at
org.netbeans.modules.cnd.modelimpl.antlr.CPPFoldingParser.parse(CPPFoldingParser.java:63)
        at
org.netbeans.modules.cnd.modelimpl.csm.core.FileParser.parse(FileParser.java:41)
        at
org.netbeans.modules.cnd.editor.parser.CppFile.startParsing(CppFile.java:120)
        at
org.netbeans.modules.cnd.editor.parser.CppFile.startParsing(CppFile.java:98)
        at
org.netbeans.modules.cnd.editor.parser.CppMetaModel$1.run(CppMetaModel.java:70)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:493)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:926)

Of the 2 files which showed folds, one was in Freeway. I can provide the
other if required (its a public source app I recently downloaded). In case
I forget, its on my home machine pucci:/usr/local/src/samples/cppxmlobj_1_0_7
(as are many of the other .hpp files which didn't show folds).

I consider this the highest priority folding issue as its not a failure in
a special case, but an entire type of file (which should show support).
Comment 1 Vladimir Voskresensky 2006-05-06 13:34:36 UTC
*** Issue 75157 has been marked as a duplicate of this issue. ***
Comment 2 Vladimir Voskresensky 2006-05-07 00:47:50 UTC
fix integrated
Comment 3 soldatov 2007-11-01 16:32:13 UTC
verified in build 200710310000
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo