Bug 7510

Summary: Opening primitive arrays in debugger window locks up Forte
Product: debugger Reporter: Willis Morse <wmorse>
Component: CodeAssignee: Antonin Nebuzelsky <anebuzelsky>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 3.x   
Target Milestone: TBD   
Hardware: PC   
OS: Windows 95/98   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Willis Morse 2000-08-28 22:17:30 UTC
Opening an array of primitives (byte[], float[], etc) in the Variable pane of
the Debugger window takes an excessively long time. I have tried reducing the
array display length to as little as 10 (down from 100), but in all cases Forte
gives me the hourglass than goes away thinking. I've let it go as long as half
an hour before giving up and force quitting (ctrl-alt-del).

I am using the latest prerelease of Forte CE 2.0

I am running Sun JDK 1.3 and Windows 98 on a 733MHz PIII with 256MB RAM. Forte
gets 128MB of RAM. No other programs are running.
Comment 1 Antonin Nebuzelsky 2000-09-05 14:03:59 UTC
This problem was caused by the fact that Forte loaded the whole array even if it
then showed only several items. The fix will immediately appear only in the main
trunk of cvs. Check into boston branch will be done after beta.
Comment 2 Jan Stola 2001-03-09 13:35:44 UTC
Reopenned due to wrong resolution.
Comment 3 Jan Stola 2001-03-09 13:35:59 UTC
Fixed.
Comment 4 Jan Stola 2001-03-09 13:38:16 UTC
Verified in Forte for Java 2.0, Netbeans (build 140) and Pilsen (build 010308).
Comment 5 Quality Engineering 2003-06-30 17:26:20 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo