Bug 7015

Summary: Explorer: Files are deleted without any warning.
Product: debugger Reporter: Jan Becicka <jbecicka>
Component: CodeAssignee: Jan Jancura <jjancura>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: jtulach
Version: 3.x   
Target Milestone: TBD   
Hardware: PC   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Jan Becicka 2000-07-10 12:52:04 UTC
1. Select some file in Explorer
2. Use Delete-key or pop-up menu | Delete
3. File is removed without any warning or confirmation dialog

[Build 1053]
Comment 1 Jan Becicka 2000-07-10 13:51:59 UTC
File | Preferences | System Settings | Confirm Delete is set to True. If this
setting is set to False and then back to True the problem is fixed.
Comment 2 Jaroslav Tulach 2000-07-13 13:00:59 UTC
The debugger is causing the problem. Here is the stacktrace that disables the
confirmation dialog:

        at
org.openide.explorer.ExplorerActions.setConfirmDelete(ExplorerActions.java:108)
        at
org.openide.explorer.ExplorerPanel.setConfirmDelete(ExplorerPanel.java:195)
        at
org.netbeans.modules.debugger.support.nodes.DebuggerView.<init>(DebuggerView.jav
a:67)

Please change this code. My suggestion would be to use your own ExplorerAction
object (I guess that DebuggerView is subclass of ExplorerPanel):

  // add private variable
  private ExplorerActions actions = new ExplorerActions ();

  protected void componentActivated () {
    actions.attach (getExplorerManager ());
  }

  protected void componentDeactivated () {
    actions.detach ();
  }

Ok?
Comment 3 Jesse Glick 2000-07-18 19:59:59 UTC
Gaak. We *really* need a better way to do this. IMHO
ExplorerActions/DeleteAction should never display a dialog, this should be a
function of the DataNode.delete, and there should be some standard way in the
APIs to tell if something is being called interactively or not.
Comment 4 Quality Engineering 2003-06-30 17:26:37 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo