Bug 68844

Summary: SQL Editor Will Not Execute SQL Scripts
Product: db Reporter: William Leonard <bleonard>
Component: SQL EditorAssignee: Andrei Badea <abadea>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: hsalameh, rcking75
Version: 5.x   
Target Milestone: 5.x   
Hardware: PC   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description William Leonard 2005-11-16 20:18:09 UTC
The NetBeans project system recognizes sql files and even allows you to
double-click a sql file to open it in the SQL editor. However, the SQL Editor
fails to execute that file.

Note, according to the NetBeans help documentation, this is possible:

"You can use the SQL Editor to create, edit and execute any SQL files in your
project. To open an SQL file, right-click the SQL file (    ) in the Projects or
Files window and choose Open. You can also double-click the icon to open the
file in the SQL Editor."
Comment 1 Andrei Badea 2005-11-18 09:15:13 UTC
This is as designed for 5.0, although the help is a little bit misleading. The
execution of scripts consisting of multiple statements is planned for the next
version:

http://db.netbeans.org/uispecs/sqleditor/sqleditor-ui-spec-promo-g.html
Comment 2 Andrei Badea 2006-02-16 11:02:55 UTC
*** Issue 18475 has been marked as a duplicate of this issue. ***
Comment 3 Andrei Badea 2006-03-02 10:15:05 UTC
Implemented in the release55 branch.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo