Bug 54850

Summary: Dependent modules jars are not added to project classpath
Product: apisupport Reporter: Nam Nguyen <nnguyen>
Component: ProjectAssignee: Jesse Glick <jglick>
Status: CLOSED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 4.x   
Target Milestone: 4.x   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Nam Nguyen 2005-02-10 21:51:21 UTC
Create a NB module project using cluster harness.
 If you don't have NB source, just netbeans
binaries, the dependent module jars are not added
to the project classpath.  The result is that you
will get red syntax error underline everywhere. 
Code completion does not work.  Build still
successful.  In the console, you will get:

[org.netbeans.modules.apisupport.project] Warning
- could not find dependent module path openide for
NbModuleProject[MasterFileObject@1aac78d[file:/home/nam/buzz/nb_all/snipe/]]
[org.netbeans.modules.apisupport.project] Warning
- could not find dependent module path
openide/loaders for
NbModuleProject[MasterFileObject@1aac78d[file:/home/nam/buzz/nb_all/snipe/]]

This is a big obstacle for JSE developer to use
NB40.  There seems to be no work-around that I
know off.
Comment 1 Rich Unger 2005-02-10 21:59:40 UTC

*** This issue has been marked as a duplicate of 52354 ***
Comment 2 Jesse Glick 2005-03-26 16:40:21 UTC
Right.
Comment 3 Nam Nguyen 2005-03-28 15:22:03 UTC
I have found the workaround in JSE (Java Studio Enterprise) build environement
which is modeled after NetBeans build environment ratrher than cluster-harness.
 We have to include all NetBeans clusters in nbbuild/cluster.properties.  We
also have to includes all NetBeans modules in nbbuild/templates/modules.xml.

For build environment based on NetBeans binaries, it would be better if these
information are derived dynamically from the unzipped netbeans binary tree. 
Maybe some additional data dictionary needs to be packaged along with the
binaries to help the derivation?

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo