Bug 45689

Summary: Can not add JDBC driver to NetBeans
Product: db Reporter: olegkon <olegkon>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: CLOSED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 3.x   
Target Milestone: 4.x   
Hardware: PC   
OS: Windows XP   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Log file

Description olegkon 2004-06-29 16:34:15 UTC
Sometimes getting NullPointer exception when 
clicking "Find" [main class in JDBC driver], but 
even when I click Find and there are
no exceptions, I click OK and driver is not 
getting added.

java.lang.NullPointerException
	at 
javax.swing.plaf.basic.BasicProgressBarUI.updateS
izes(BasicProgressBarUI.java:433)
	at 
javax.swing.plaf.basic.BasicProgressBarUI.getBox
(BasicProgressBarUI.java:375)
	at 
com.sun.java.swing.plaf.windows.WindowsProgressBa
rUI.paintIndeterminate
(WindowsProgressBarUI.java:142)
	at 
javax.swing.plaf.basic.BasicProgressBarUI.paint
(BasicProgressBarUI.java:333)
	at javax.swing.plaf.ComponentUI.update
(ComponentUI.java:142)
	at javax.swing.JComponent.paintComponent
(JComponent.java:541)
	at javax.swing.JComponent.paint
(JComponent.java:808)
	at javax.swing.JComponent.paintChildren
(JComponent.java:647)
	at javax.swing.JComponent.paint
(JComponent.java:817)
	at 
javax.swing.JComponent.paintWithOffscreenBuffer
(JComponent.java:4787)
	at 
javax.swing.JComponent.paintDoubleBuffered
(JComponent.java:4740)
	at 
javax.swing.JComponent._paintImmediately
(JComponent.java:4685)
	at 
javax.swing.JComponent.paintImmediately
(JComponent.java:4488)
	at 
javax.swing.RepaintManager.paintDirtyRegions
(RepaintManager.java:410)
[catch] at 
javax.swing.SystemEventQueueUtilities$ComponentWo
rkRequest.run(SystemEventQueueUtilities.java:117)
	at 
java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:178)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:454)
	at 
java.awt.EventDispatchThread.pumpOneEventForHiera
rchy(EventDispatchThread.java:201)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarc
hy(EventDispatchThread.java:151)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarc
hy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at 
org.netbeans.core.windows.services.NbPresenter.su
perShow(NbPresenter.java:722)
	at 
org.netbeans.core.windows.services.NbPresenter.do
Show(NbPresenter.java:765)
	at 
org.netbeans.core.windows.services.NbPresenter.ru
n(NbPresenter.java:753)
	at org.openide.util.Mutex.doEventAccess
(Mutex.java:924)
	at org.openide.util.Mutex.readAccess
(Mutex.java:158)
	at 
org.netbeans.core.windows.services.NbPresenter.sh
ow(NbPresenter.java:738)
	at 
org.netbeans.modules.db.explorer.actions.AddDrive
rAction.performAction(AddDriverAction.java:103)
	at 
org.openide.util.actions.NodeAction$3.run
(NodeAction.java:440)
	at 
org.openide.util.actions.CallableSystemAction.doP
erformAction(CallableSystemAction.java:116)
	at 
org.openide.util.actions.NodeAction$DelegateActio
n.actionPerformed(NodeAction.java:438)
	at 
javax.swing.AbstractButton.fireActionPerformed
(AbstractButton.java:1786)
	at 
javax.swing.AbstractButton$ForwardActionEvents.ac
tionPerformed(AbstractButton.java:1839)
	at 
javax.swing.DefaultButtonModel.fireActionPerforme
d(DefaultButtonModel.java:420)
	at 
javax.swing.DefaultButtonModel.setPressed
(DefaultButtonModel.java:258)
	at javax.swing.AbstractButton.doClick
(AbstractButton.java:289)
	at 
javax.swing.plaf.basic.BasicMenuItemUI.doClick
(BasicMenuItemUI.java:1113)
	at 
javax.swing.plaf.basic.BasicMenuItemUI$MouseInput
Handler.mouseReleased(BasicMenuItemUI.java:943)
	at java.awt.Component.processMouseEvent
(Component.java:5100)
	at java.awt.Component.processEvent
(Component.java:4897)
	at java.awt.Container.processEvent
(Container.java:1569)
	at java.awt.Component.dispatchEventImpl
(Component.java:3615)
	at java.awt.Container.dispatchEventImpl
(Container.java:1627)
	at java.awt.Component.dispatchEvent
(Component.java:3477)
	at 
java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:3483)
	at 
java.awt.LightweightDispatcher.processMouseEvent
(Container.java:3198)
	at 
java.awt.LightweightDispatcher.dispatchEvent
(Container.java:3128)
	at java.awt.Container.dispatchEventImpl
(Container.java:1613)
	at java.awt.Window.dispatchEventImpl
(Window.java:1606)
	at java.awt.Component.dispatchEvent
(Component.java:3477)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:456)
	at 
java.awt.EventDispatchThread.pumpOneEventForHiera
rchy(EventDispatchThread.java:201)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarc
hy(EventDispatchThread.java:151)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:145)
	at 
java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:100)


Rebooting, reinstalling NetBeans didn't help.

It all started after I added a few drivers 
successfully,
but it geve me error something like "not enough 
information"
with a bunch of empty [],(), etc.

Then I put JDBC driver inside NetBeans 
[/lib/ext] and added it successfully,  
but it was connecting to some unknown 
database  ;-0

So we removed all JDBC drivers from the list 
including a bridge one.
And I was never able to add JDBC driver to 
NetBeans again.
Comment 1 olegkon 2004-06-29 16:36:22 UTC
Created attachment 16063 [details]
Log file
Comment 2 Richard R. Brandt 2004-06-30 14:57:32 UTC
I am having this same issue, except...  I sware when I installed 3.6 
I was able to install JDBC drivers.  I am using Oracle and Informix.  
I had some other problems so I re-installed, asfter wiping all 
files.  

I am CERTAIN I am attempting to load the correct JDBC drivers, Oracle 
1.2 file classes1.2.jar.  NetBeans finds th correct class and 
everything, but when I click "OK" the driver doesn't get loaded.

rrbrandt@aep.com
Comment 3 ehucka 2004-07-12 10:10:42 UTC
Reassigning to db module.
Comment 4 Radko Najman 2004-07-14 17:07:42 UTC
It looks like a duplicase of the issue #38385.

*** This issue has been marked as a duplicate of 38385 ***
Comment 5 dmladek 2004-07-16 13:27:32 UTC
Yes seems like a dup
Comment 6 dmladek 2004-08-19 09:25:34 UTC
just closing it
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo