Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 39160

Summary: pushing SHIFT+TAB throws exception
Product: platform Reporter: bnv <bnv>
Component: Outline&TreeTableAssignee: _ tboudreau <tboudreau>
Status: VERIFIED INVALID QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: bnv, ccv, mbudris, petersl, vgorr
Version: 3.xKeywords: A11Y
Target Milestone: TBD   
Hardware: Sun   
OS: SunOS   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 33281    
Bug Blocks:    
Attachments: ide.log

Description bnv 2004-01-23 09:15:20 UTC
Product Version: Sun ONE Studio 8 (Build 040113)
-- Rainier build38.0
IDE Version:   IDE/1 spec=3.42.1 impl 040113)
Operating System: SunOs version 5.8 running on sparc
Java:	         1.4.1_07

Start sunstudio8.
To display the Debugger Window push Cntr+5 key.
Set focus in the empty table with TAB key.

ISSUE: If try to press the SHIFT+TAB key on the
empty table the exception will be thrown
Comment 1 bnv 2004-01-23 09:19:28 UTC
Created attachment 13044 [details]
ide.log
Comment 2 Peter Zavadsky 2004-01-26 12:47:37 UTC
Window system doesn't use that JTable. If the JTable is in the
debugger window (what I think it is), it belongs there.
Comment 3 Maros Sandor 2004-01-27 14:19:34 UTC
Debugger does not use tables/table models directly. I think the 
problem is in Swing/AWT but I decided to first assign this to 
openide/TreeTableView for evaluation.
Comment 4 _ tboudreau 2004-01-28 07:54:20 UTC
Well, anything in the current TTV is suspect, but I don't see any netbeans code at all in 
the stack trace, so it's not clear whose problem it is from a casual review.

Adding this issue to the TTV rewrite umbrella issue - either way we can ensure it 
doesn't happen once it's rewritten.  FYI, I'm investigating a few options for reusing 
other existing tree table implementations to get a leg up on getting it rewritten, and 
in parallel prototyping approaches for doing the rewrite in what seems to me the most 
solid way possible.
Comment 5 _ tboudreau 2004-07-21 23:55:51 UTC
Appears to have been fixed by my fix of the sorting null-element issue - cannot reproduce 
it now, but can on a pre-fix build.
Comment 6 Marian Mirilovic 2005-07-12 10:07:53 UTC
closed
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo